Как соединить свитч и роутер в циско
Перейти к содержимому

Как соединить свитч и роутер в циско

  • автор:

Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Как настроить маршрутизатор cisco

Настройка серверов windows и linux

Всем привет сегодня хочу рассказать вам, как настроить маршрутизатор ciscoили организовать сеть для небольшого офиса. Поговорим об отличиях коммутатора 3 уровня и маршрутизатора, и разберем схему организации малого офиса и среднего, с использованием роутера Cisco. Думаю это интересная тема и весьма часто встречающаяся.

Отличия роутера Cisco от коммутатора 3 уровня

Напомню в предыдущей статье мы настроили коммутатор cisco в качестве ядра, работающего на 3 уровне модели OSI, и разобрали, что он производительнее и дешевле, чем router cisco. Так, что же тогда заставляет покупать маршрутизаторы Cisco, все дело в мозгах, которые дают функционал, такой как:

Без которого сложно представить как связывать удаленные офисы с центральным. Такая вот хитрая политика партии у Cisco.

Схема для малого офиса

схема небольшого офиса филиала

Создаем VLAN2, VLAN3, VLAN4. Логинимся на ваш cisco 2960 и переходим в режим конфигурирования/

enable
conf t
valn 2
name VLAN2
exit
vlan 3
name VLAN3
exit
vlan 4
name VLAN4
exit

настраиваем vlan cisco 2960

теперь определим каждый компьютер в нужный vlan. PC0 в vlan 2, PC1 в vlan 3, PC2 в vlan 4. У меня это порты fa0/1, fa0/2 и fa0/3.

int fa 0/1
switchport mode access
switchport access vlan 2
exit
int fa 0/2
switchport mode access
switchport access vlan 3
exit
int fa 0/3
switchport mode access
switchport access vlan 4
exit
do wr mem

настройка vlan cisco

Следующим шагом будет настроить trunk порт до нашего роутера Cisco 1841. Вводим следующие команды

Выбираем нужный интерфейс

Выставляем режим trunk

switchport mode trunk

разрешаем определенные vlan

switchport trunk allowed vlan 2,3,4
end
wr mem

настраиваем trunk cisco

Все работы на коммутаторе Cisco 2960 закончены, переходим к нашему роутеру.

Настройка маршрутизатор cisco 1841

Начнем настраивать маршрутизатор cisco 1841, для того чтобы он маршрутизировал трафик между vlan и был в качестве интернет шлюза. По умолчанию все порты на маршрутизаторе находятся в выключенном состоянии, включим порт куда воткнут патчкорд от коммутатора cisco 2960, у меня это fa 0/0.

enable
conf t
int fa 0/0
no shutdown

У вас появится нечто подобное, сообщая вам что порт стал быть активным.

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

настройка порта роутера cisco-1

Порт стал зеленым

настройка порта роутера cisco-2

Следующим шагом нужно создать сабъинтерфейсы по количеству vlan. У роутеров просто нет vlan и их роль выполняют сабъинтерфейсы, где определенному vlan соответствует subinerface.

Создаем subinterface для vlan 2

int fa 0/0.2

указываем что он относится и случает пакеты vlan 2

encapsulation dot1Q 2

настраиваем ip адрес

ip address 192.168.1.251 255.255.255.0
no shutdown
exit

и сохраняем настройки командой

настройка subinterfase cisco

Настроим подобный образом subinterface для vlan 3,4

int fa 0/0.3
encapsulation dot1Q 3
ip address 192.168.2.251 255.255.255.0
no shutdown
exit
int fa 0/0.4
encapsulation dot1Q 4
ip address 192.168.3.251 255.255.255.0
no shutdown
exit

ip routing
do wr mem

Пробуем пропинговать с компьютера PC0 компьютер PC3 и PC2. Как видим на скриншоте все ок.

ping cisco

Вот так вот просто организовать локальную сеть в очень небольшом филиале и где быстро производится настройка маршрутизатора cisco. настройку NAT мы произведем в другой статье.

Схема для среднего офиса

Вот как выглядит схема локальной сети среднего офиса. Есть маршрутизатор cisco 2911, выступающий в роли интернет шлюза. Есть ядро сети коммутатор 3 уровня Cisco 3560. Он будет маршрутизировать локальный трафик между vlan сети. В Cisco 3560 воткнуты 3 коммутатора второго уровня Cisco 2960, которые уже подключают в себя конечные устройства. В сети есть 3 vlan 2,3,4.

схема среднего офиса

Настройка Switch1

Начнем с настройки Switch1, сегмента серверов. Логинимся в режим глобальной конфигурации.

enable
conf t
vlan 4
name VLAN4
exit

Закинем порты fa 0/1-2 в VLAN4

int range fa 0/1-2
switchport mode access
switchport access vlan 4
exit
do wr mem

Настроим trunk порт fa 0/3, разрешать будем только трафик vlan4

int fa 0/3
switchport mode trunk
switchport trunk allowed vlan 4
exit
do wr mem

Настройка Switch2

Все с сегментом серверов мы закончили. Переходим к такой же настройке на Switch2 и 3. И так Switch2 Cisco 2960.

Первым делом создаем vlan 2 и vlan3.

enable
conf t
vlan 2
name VLAN2
exit
vlan 3
name VLAN3
exit

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

int fa 0/1
switchport mode access
switchport access vlan 2
exit
int fa 0/2
switchport access vlan 3
exit

Настроим trunk порт на интерфейсе fa 0/3

int fa 0/3
switchport mode trunk
switchport trunk allowed vlan 2,3,4
exit
do wr mem

Настройка Switch3

Тот же фокус проводим с настройкой Switch3 Cisco 2960

Первым делом создаем vlan 2 и vlan3.

enable
conf t
vlan 2
name VLAN2
exit
vlan 3
name VLAN3
exit

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

int fa 0/1
switchport mode access
switchport access vlan 2
exit
int fa 0/2
switchport access vlan 3
exit

Настроим trunk порт на интерфейсе fa 0/3

int fa 0/3
switchport mode trunk
switchport trunk allowed vlan 2,3,4
exit
do wr mem

Настройка ядра сети

Приступаем к настройке маршрутизации, на ядре Cisco 3560, все три его порта нужно настроить как trunk, создать vlan и назначить им ip.

enable
conf t

создаем vlan 2,3,4
vlan 2
name VLAN2
exit
vlan 3
name VLAN3
exit
vlan 4
name VLAN4
exit

Задаем статический ip адрес vlan2,3,4

int vlan 2
ip address 192.168.1.251 255.255.255.0
no shutdown
exit
int vlan 3
ip address 192.168.2.251 255.255.255.0
no shutdown
exit
int vlan 4
ip address 192.168.3.251 255.255.255.0
no shutdown
exit

Настраиваем trunk порты

int fa 0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit
int fa 0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit
int fa 0/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit

Включаем маршрутизацию и сохраняем конфигурацию
ip routing
do wr mem

Ping будет производиться с компьютера PC3. Как видим, сервера и обычные компьютеры разделены.

проверка пинга

О настройке интернета и NAT поговорим в следующих статьях на данную тему. Как видите конфигурирование маршрутизаторов cisco, не такое уж и сложное дело.

Популярные Похожие записи:
  • Сравнение маршрутизаторов Cisco и Juniper, что лучше в 2022 году?
  • Не открывается сайт nic.ru из-за ddos-атакиНе открывается сайт nic.ru из-за ddos-атаки
  • Что такое виртуальный сетевой адаптер и в каких случаях он может пригодиться?Что такое виртуальный сетевой адаптер и в каких случаях он может пригодиться?
  • Контроллер домена грузится в Safe Mode
  • Как массово поменять пароль локального администратора в домене
  • Поиск mac-адреса на DHCP с помощью PowerShellПоиск mac-адреса на DHCP с помощью PowerShell

Мар 29, 2019 23:36 Автор — Сёмин Иван

14 Responses to Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Здравствуйте. Мне нужно наоборот разграничить сеть. Есть небольшой офис, в нем на циске 890 настроено несколько влан-ов. И нужно сделать так, чтоб они не видели друг друга. Через ACL никак не получается у меня настроить

Иван Семин :
А можете нарисовать схему сети вашей в cisco packet tracer?
Вот, сделал _ttps://drive.google.com/file/d/0B03T___QidaxSUwwNmNGNUZIQjQ/view?usp=sharing

ПК получают адреса 30.2 и 50.2 Нужно, чтоб 192.168.30.2 не видел 192.168.50.2, но оба видели 192.168.0.1

Привет. Меня тоже интересует етот вопро. Спасибо.

В описанной настройке транков кор-свича не хватает разрешения на vlan 4, вероятно просто забыли указать.

Доброй ночи помогите сделать задание,схема Центральный офис и 4 территориально удаленных филиала Пожалуйста!

Мне требуется развернуть похожую сеть на заводе. В связи с чем возник вопрос — возможно ли вместо свича cisco 2960 использовать промышленный коммутатор на 8 портов https://www.raisecom.su/equipment/ethernet_switches/promyshlennyj_kommutator_8_portov/
?

Спасибо, разобрался в этом вопросе.

> не хватает разрешения на vlan 4, вероятно просто забыли указать
Не забыли. С ним vlan 4 после ip routing не останется изолированным.

Зачем нам здесь нужен маршутизатор, обьясните пожалуйста)))

Если vlan4 не прописать на обоих концах транка, то пакеты с тегом vlan4 не пройдут, и да, трафик vlan4 останется полностью изолированным, даже от ядра. Объясните тогда зачем нужны пакеты с тегом vlan4 на свичах 2 и 3? Ведь вы не планируете на этих свичах серверы vlan4.

ошибка)vlan2,3 на TRUNK port fa0/3 Multi swich >Switch1. А с другой стороны с SW1 смотрящий на мульти свич указали только 4 VLAN.
Вопрос…После команды ip routing vlan начинают перебрасывать пакеты между собой.
А зачем тогда VLAN? Он получается перестает выполнять свою функцию изоляции между подсетями.

если на двух концах транка разные влан кажется это может привести к петле

Добавить комментарий

Поиск по сайту

Подписка на youtube канал

Выберите рубрику

Active directory, GPO, CA Android Apple ASUS, Sony VAIO CentOS Cisco, Mikrotik Debian, FreeBSD DNS Exchange, Power Shell HP/3Com Hyper-V IBM IIS и FTP, web и seo Juniper Lenovo, intel, EMC, Dell Microsoft Office Microsoft SQL server, Oracle Microsoft System Center NetApp Network, Телефония News Raid, LSI, Adaptec Supermicro Ubuntu Utilities Veeam Backup & Replication, Windows Server Backup Vmware, VirtualBox Windows 7 Windows 8/8.1 Windows 10, Windows 11 Windows 2008/2008 R2 Windows 2012/2012 R2 Windows Server 2016, Windows Server 2019, Windows Server 2022 WordPress, 1C Битрикс Безопасность, Kali СХД Сертификация перед сном

Подписка не Telegram

Подписка на телеграм канал pyatilistnikorg

Последние записи

  • Не запускается файловая роль на Failover Cluster
  • Ошибка the request failed or the services did not respond in a timely fashion
  • Ошибка This action is only valid for that are currently installed
  • Ошибка 0x80042306 при создании VSS снимка
  • Перенос доменов с GoDaddy в Reg.ru, мой опыт

Cisco. Первый выпуск. Соединяем две сети.

image

С чего начинается Cisco-роутер? Правильно, с консольного кабеля.
Это тот светло-голубой провод с разъемами RS-232 и RJ-45, который шел вместе с оборудованием. Его нужно подключить к компьютеру к свободному COM порту. Теперь с вашим железом можно делать все что угодно. Если, конечно, не установлен пароль на консольные подключения (о том, как побороть чужой пароль на вашем железе поговорим позже).

Итак, открываем программу-клиент терминального подключения, например, PuTTY. В программе указываем порт соединения (COM1) и скорость подключения (9600).
Что видим? Черный экран, мигающий курсор и больше ничего? Значит, скорее всего, скорость подключения на роутере выставлена другая. Как правило, это может быть скорость 115200. Если и она не подходит (а это — редкость), то придется подбирать. В любом случае, еще стоит проверить, какой указан СOM порт, к которому произведено подключение.

Отлично, разобрались! Все нормально и мы видим приглашение от роутера. По умолчанию оно будет выглядеть так: Router>
Это значит, что мы находимся в пользовательском режиме. Из этого режима доступно совсем немного команд. Все эти команды позволяют лишь наблюдать за работой роутера, но не дают возможности вносить изменения в конфигурацию. Из этого режима можно выполнить, например, команду Ping или show ip interface.

Для того, чтобы изменять рабочую конфигурацию (читай, настройку) роутера, необходимо войти в привилегированный режим. Привилегированный режим может быть защищен паролем. Для того чтобы войти в привилегированный режим, нужно набрать команду enable. После этого приглашение командной строки изменится на Router#

Здесь уже доступно намного больше команд. В этом режме можно вносить изменения в рабочую конфигурацию и сохранять измененную конфигурацию в ПЗУ.

Но основная настройка роутера ведется из режима глобальной конфигурации. В него можно попасть из привилегированного режима выполнением команды configure terminal. Приглашение изменится на Router(config)#. Как вы уже заметили, приглашение командной строки говорит о том, в каком режиме вы находитесь.

Ближе к делу.

Для начала давайте сделаем самое простое — соединим две сети с помощью нашего маршрутизатора.
Сеть Internal имеет диапазон адресов 192.168.10.1/24, адрес роутера в нем — 192.168.10.254, сетевой адаптер — FastEthernet0/0
Сеть External имеет диапазон адресов 10.54.0.0/16, адрес роутера в нем — 10.54.0.1, сетевой адаптер — FastEthernet0/1.
В режиме глобальной конфигурации вводим команду Interface FastEthernet0/0. Приглашение станет таким: Router(config-if)#. Интерфейс по умолчанию не имеет никакого адреса и даже выключен. Сначала введем IP-адрес. Это делается следующей командой: ip address 192.168.10.254 255.255.255.0.
Помните, что интерфейс выключен? Включается он командой no shutdown. Если все хорошо, то пробежит надпись:

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Первая строка говорит о том, что с сетевым интерфейсом все хорошо с точки зрения физического и канального уровня (сетевой кабель подключен и на другом его конце работает совместимое оборудование). Вторая строка говорит о том, что Сетевой уровень (IP Layer) тоже работает как надо.

Дальше нужно выйти из режима конфигурации интерфейса FastEthernet0/0, войти в интерфейс FastEthernet0/1 и настроить его параметры IP.
С этим вы и сами справитесь.

Проверить, правильно ли все настроено, можно вернувшись в привилегированный режим (команда exit) и выполнив команду show ip interface brief. Она покажет информацию о состоянии сетевых интерфейсов. Вывод команды будет примерно таким:

Router#show ip interface brief
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.10.254 YES manual up up

FastEthernet0/1 10.54.0.1 YES manual up up

Ура!

Готово! Роутер может передавать пакеты из одной сети в другую и обратно.
Почти готово =) Все изменения и настройки, которые мы сейчас вносили, сохранены только в оперативной памяти роутера. Чтобы конфигурация сохранилась и после перезагрузки, ее нужно скопировать в ПЗУ. Делается это проще простого. Из привилегированного режима вводится команда copy running-config startup-config. Теперь перезагрузка не страшна!

Да, еще одна маленькая деталь. Если вы включаете роутер, у которого отсутствует конфигурация, то IOS предложит воспользоваться визардом для настройки основных параметров работы роутера. Вежливо откажите ему. Зачем просто, когда можно сложно? =)

Итого:

Для работы нам понадобится 4 основных режима конфигурации:

Пользовательский режим: Router>
Привилегированный режим: Router#
Режим глобальной конфигурации: Router(config)#
Режим конфигурации объекта(интерфейса, протокола маршрутизации и т.д.): Router(config-if)#

Вот и все. Согласитесь, вы думали, что будет сложнее!

В следующем выпуске я планирую написать про использование симулятора Packet Tracer 5.0 и эмулятора GNS3. Попробую подготовить видеоролик о том, как работают эти нужные и полезные программы. Выпуски я планирую готовить раз в неделю.

Подключение трёх компьютеров через три роутера и свитч (в Cisco Packet Tracer)

Author24 — интернет-сервис помощи студентам

Просмотрел кучу информации в интернете. Не смог найти подобных схем сети, чтобы можно было посмотреть как данную лабораторную решить. Выручайте, люди добрые. Нужно, чтобы PC4 успешно пинговал PC5 и PC6. Подскажите хотя бы в каком направлении мне мыслить. Поднять порты на роутерах могу и дать им ip-адреса. Так же адреса присваиваю и компьютерам. Компьютеры со своими роутерами пингуются. Что делать дальше — не знаю. Нужно ли на свиче создавать вланы, определять порты (и если да, то они будут access или trunk) и как настроить маршрутизацию?. Буду очень признателен за помощь.

Лучшие ответы ( 1 )
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
Ответы с готовыми решениями:

Настройка роутера (в Cisco Packet Tracer)
У меня есть сеть (см. картинку). ip адреса пк слева: 192.168.1.1, 192.168.1.2, 192.168.1.3. switch0.

Не идет дальше первого роутера (Cisco Packet Tracer)
Добрый вечер, проблема, есть задание постороил всё задал корректно на первый взгдл но пк не.

Как соединить два роутера? (в Cisco Packet Tracer)
Доброе утро, форумчане. Нужна небольшая помощь в Cisco Packet Tracer. Нужно создать КС, как.

Нет подключения роутера, простая сеть в Cisco Packet Tracer
Всем доброго времени суток! В общем такое дело, решил изучить сетевые технологии, в колледже сети.

Эксперт по компьютерным сетям

3949 / 1539 / 297
Регистрация: 23.06.2009
Сообщений: 5,473

полностью задание напишите и приложите файл проекта (в zip)
план ip адресации задается или самому придумать?
покажите план адресации

98 / 94 / 12
Регистрация: 12.02.2013
Сообщений: 718

sergeeandos, Оставь на свиче все в дефолтном влане,
Если роутеры используют белые адреса а ПК серые, то необходимо использовать NAT и GRE туннели.
Если же только серые адреса используются, то необходимо настроить IP адресацию, и маршрутизацию.
В твоем случае можно использовать OSPF или RIPv2, так же можно использовать статические маршруты.
Однако динамическая маршрутизация будет предпочтительнее, настраивается:

#(config) router ospf либо #(config) router rip

Регистрация: 14.06.2016
Сообщений: 8

Задание полностью звучит так:
«Необходимо скачать Cisco Packet Tracer и реализовать схему как на
картинке. PC4 должен успешно пинговать PC5 и PC6. Адресацию можете использовать любую. Пароли на устройства ставить не нужно.»
Прикладываю файл, который я создал.

Я решил использовать серые адреса, присвоил адреса портам роутера (и поднял их) и компьютерам. В конфигурации свича по совету не полез. С динамической маршрутизацией не знаком — буду читать, пробовать.

Zadanie1.rar (67.9 Кб, 69 просмотров)

Регистрация: 14.06.2016
Сообщений: 8

Когда пробовал настроить статическую маршрутизацию, выдавалась ошибка. Например чтобы левый роутер видел правый верхний пк через правый верхний роутер:

Router>en Router#conf t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#ip route 192.168.2.2 255.255.255.0 192.168.20.1 %Inconsistent address and mask Router(config)#

Эксперт по компьютерным сетям

3949 / 1539 / 297
Регистрация: 23.06.2009
Сообщений: 5,473

1. на ПК не прописаны шлюз по умолчанию
2. на маршрутизаторах, интрефесы которых подключены к коммутатору, ip адреса должны быть из одной сети (например 192.168.10.0/24)

PC>ipconfig FastEthernet0 Connection:(default port) Link-local IPv6 Address. FE80::290:CFF:FE42:A71C IP Address. 192.168.1.2 Subnet Mask. 255.255.255.0 Default Gateway. 192.168.1.1 PC>tracert 192.168.2.2 Tracing route to 192.168.2.2 over a maximum of 30 hops: 1 0 ms 0 ms 0 ms 192.168.1.1 2 0 ms 1 ms 0 ms 192.168.10.2 3 0 ms 0 ms 0 ms 192.168.2.2 Trace complete. PC>ping 192.168.2.2 Pinging 192.168.2.2 with 32 bytes of data: Reply from 192.168.2.2: bytes=32 time=0ms TTL=126 Reply from 192.168.2.2: bytes=32 time=0ms TTL=126 Reply from 192.168.2.2: bytes=32 time=0ms TTL=126 Reply from 192.168.2.2: bytes=32 time=0ms TTL=126 Ping statistics for 192.168.2.2: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 0ms, Maximum = 0ms, Average = 0ms PC>

Как настроить роутер Cisco: пример и реализация от WiFiGid

WiFiGid

Всем привет! Сегодня я на простом примере расскажу вам про настройку роутера Cisco (2911, 1841, 881 и другие модели). Я выдумал некую простую схему с примером, которая позволит вам понять, как подключить локальную сеть к интернету через наш маршрутизатор. Я покажу пример настройки через консоль. Но вы можете делать конфигурирование через программу «Cisco Packet Tracer» – видеоинструкцию смотрим в конце статьи.

Пример подключения

Представим себе, что у нас есть один роутер Cisco. С помощью маршрутизатора мы должны подключить офис с несколькими компьютерами. Для коннекта всех локальных машин будем использовать коммутатор. Fa 4 и Fa 0 – это внешний и внутренний физический интерфейс. Также у нас есть:

  • 277.146.101.1 – это шлюз провайдера.
  • 277.146.101.2 – это внешний IP адрес роутера, его выдает провайдер.
  • 192.168.1.1 – это локальный IP адрес.

Как настроить роутер Cisco: пример и реализация от WiFiGid

Я думаю, схема достаточно понятная и простая.

ШАГ 1: Подключение к маршрутизатору

Для подключения мы будем использовать вот такой вот кабель, который обычно идет в комплекте со всем подобным оборудованием.

Как настроить роутер Cisco: пример и реализация от WiFiGid

С одной стороны консольного кабеля должен быть COM-порт (RS 232). Подключаем один конец в CONSOLE (может иметь надпись CON) порты.

Как настроить роутер Cisco: пример и реализация от WiFiGid

Вы можете столкнуться с проблемой, что у современных компов и ноутов нет подобного входа. Поэтому можно использовать USB переходник.

Как настроить роутер Cisco: пример и реализация от WiFiGid

После подключения скачиваем программку PuTTY – она бесплатная и достаточно удобная. Очень важный момент – в разделе «Connection type» после запуска установите значение «Serial».

И далее нажимаем по кнопке «Open». Если у вас возникли трудности и подключение не происходит, то проверьте в «Диспетчере устройств», какой COM порт используется. Может быть баг, что порт указан не тот. Особенно этот баг проявляется при использовании переходника USB-COM.

Как настроить роутер Cisco: пример и реализация от WiFiGid

Далее вы должны увидеть приветственную надпись в запрос ввода логина и пароля.

ШАГ 2: Reset настроек

Итак, в первую очередь нам нужно полностью очистить старые настройки – они нам ни к чему, все будем делать с нуля (так сказать). Изначально вы увидите вот такую надпись:

Но нам нужно запустить роутер с правами администратора, чтобы вместо стрелочки стояла решетка (#). Для этого вводим команду:

Теперь сначала удаляем старый конфиг, а потом ребутаем аппарат:

router# write erase
router# reload

Нужно будет немного подождать. После этого роутер загрузится и выведет сообщение – использовать стандартную конфигурацию? – отвечаем:

Как настроить роутер Cisco: пример и реализация от WiFiGid

ШАГ 3: Конфигурация интерфейсов

В первую очередь давайте назовем наше устройство для удобства обращения через команду. Я назвал его: «WIFIGID-ROUTER» – смотрим на картинку. Вообще, если у вас будут возникать какие-то вопросы по командам, то смотрите на схему в начале статьи. Итак, обзываем наш роутер:

router#conf t
router (config)#hostname WIFIGID-ROUTER

После этого вместо «router» вы должны увидеть свое название. Вспомним, что у роутера есть два интерфейса,

Внутренний (связь с локальной сетью) – с адресацией:

Внешний (связь с глобальным интернетом) – понятное дело, что у нас тут будут статические настройки:

Я придумал все эти значения, просто чтобы показать настройку – вы же подставляйте свои циферки. Маршрутизатор будет выступать шлюзом, и наша задача связать две эти сети и дать клиентам доступ в интернет.

Давайте введем настройки внешнего статического адреса:

WIFIGID-ROUTER #conf t
WIFIGID-ROUTER (config)#
interface Fa 4
ip address 227.146.101.2 255.255.255.252
no shutdown

Для подключения к интернету мы используем четвёртый интерфейс. Выше я задал внешний IP как 227.146.101.2, после этого прописал маску и запустил настройку последней командой. Ах да, не забудьте подключить интернет кабель от провайдера. В качестве проверки пингуем сначала сам роутер:

WIFIGID-ROUTER #ping 227.146.101.2

А потом шлюз провайдера:

WIFIGID-ROUTER #ping 227.146.101.1

Если все хорошо, и оба устройства пингуются, идем настраивать интерфейс для связи с локальной сетью. Локальная сеть у нас будет с адресацией:

Локальный адрес роутера:

И еще один совет – обязательно оставьте пару адресов про запас. То есть диапазон адресов будет примерно от 192.168.1.2 до 192.168.1.10. Остальные уже будут использоваться клиентами и другими устройствами в локалке.

Локальный адрес роутера мы будем прописывать в VLAN:

R-DELTACONFIG#conf t
interface Vlan 1
Ip address 192.168.2.1 255.255.255.0
no shutdown
interface Fa 0
switchport access vlan 1
no shutdown

А для подключения будем использовать интерфейс «Fa 0». Что мы сделали, мы привязали сначала локальный адрес к Vlan. А потом уже VLAN привязали к физическому интерфейсу. Подключаем к этому физическому интерфейсу наш коммутатор, к которому уже будут подключены все рабочие машины, принтеры и другие сетевые устройства.

ШАГ 4: Удаленный доступ к роутеру

Чтобы вам постоянно не сидеть рядом с роутером и подключенным к нему консольным кабелем, я вам советую сразу настроить удалённый доступ. Мы будем использовать подключение по защищенному каналу SSH (второй версии).

WIFIGID-ROUTER (config)#
ip ssh ver 2
ip domain-name wifigid-router-c.ru

Сначала мы запустили SSH-2, а потом прописали произвольный домен. Теперь создаем ключ с помощью команды.

crypto key generate rsa

Далее вылезет вот такая вот надпись:

Как настроить роутер Cisco: пример и реализация от WiFiGid

Создаем пользователя с правами админа и паролем. Вместо «password» введите свой пароль.

username admin privilege 15 secret 0 password

Включаем пользователя в базу устройства:

line vty 0 4
login local

И задаем пароль для режима доступа:

enable secret 0 password-2

Опять же вместо «password-2» вводим свой пароль. После этого вы можете использовать любую программу с поддержкой SSH для доступа из локальной сети к этому роутеру.

ШАГ 5: Настройка шлюза

Теперь нам нужно подключиться к шлюзу провайдера:

WIFIGID-ROUTER (config)#
ip route 0.0.0.0 0.0.0.0 227.146.101.1

После этого пингуем любой внешний сайт, но лучше использовать именно IP, а не DNS адрес. Можно даже пропинговать один из DNS-серверов.

WIFIGID-ROUTER#ping 8.8.8.8

ШАГ 6: Настройка NAT

Опять же локальные компьютеры пользователя пока не имеют доступа в интернет, но мы это исправим. Для этого нам нужно настроить динамическую трансляцию локальных IP во внешний. У нас всего один внешний адрес, поэтому локальные адреса должны превращаться в него, проходя через наш роутер, выполняющий роль шлюза.

Прописываем диапазон тех адресов, которые в теории могут использоваться локальными машинами:

WIFIGID-ROUTER (config)#
ip access-list standard ACL_NAT
permit 192.168.1.0 0.0.0.255

Далее указываем наш VLAN:

Interface Vlan 1
ip nat inside

Они будет неким локальным интерфейсом, ведь в VLAN может быть сразу несколько адресов. Теперь указываем физический внешний интерфейс, к которому мы подключили провайдерский кабель:

Interface Fa 4
ip
nat outside

А теперь мы создаем NAT правило:

ip nat inside source list WIFIGID_NAT interface fa4

Далее мы уже можем из локальной сети с любого компа клиента пинговать любые интернет-адреса. Также в качестве пробы используем внешний IP адрес. Ну и в самом конце не забудьте сохранить конфиг в память роутера:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *