Что такое rout и rep на роутере
Перейти к содержимому

Что такое rout и rep на роутере

  • автор:

Как настроить роутер Билайн smart box под МТС

В роутере есть USB порт. К роутеру вы можете подключить флешку или внешний жесткий диск, для предоставления общего доступа к ним по сети, а также некоторые USB-модемы.

Начиная с версии 2.0.25 прошивки, добавлена возможность работы с 3g модемами в режиме раздачи по Wi-Fi. Для настройки необходимо зайти из-под суперпользователя и перейти в: Расширенные настройки – Другие – Wan, выбрать пункт Internet-3G и произвести необходимые настройки, а также отметить интерфейс активным (галочкой).

Роутер можно использовать в качестве повторителя (репитера). Для этого переведите аппаратный переключатель на корпусе роутера в режим REP и смените через настройки (Расширенные настройки -> Wi-Fi -> Основные параметры) переключатель с точки доступа (AP) на повторитель (Wi-Fi Repeater).

Главное, что в роутере есть скрытая полноценная настройка WAN интерфейса, позволяющая включать/отключать интерфейсы, получать адрес по DHCP, поднимать PPPoE/L2TP/3G, т. е. роутер можно заставить работать с 99% Российских провайдеров.

Но. Если мы входим в веб-интерфейс роутера из-под просто админа — логин = admin; пароль — admin, тогда нам предоставляются настройки, ограниченные провайдером Билайн.

Чтобы получить полные ROOT права производителя, необходимо логиниться под Супер Юзером, значит вводим следующие данные:

  • Логин = SuperUser
  • Пароль — Beeline$martB0x

Начиная с версии прошивки • 0.25, пароль супер-юзера изменен на серийный номер устройства SFXXXXXXXXXX (указан на наклейке сзади устройства). Значит используем следующие данные:

  • Логин = SuperUser
  • Пароль — SFXXXXXXXXXX

Зайдя из-под супер-юзера мы получаем возможность изменять любые настройки, например поменять L2TP на PPPOE, т. е. использовать полноценно роутер с другими провайдерами, отличными от Билайн.

Роутер Билайн Smart Box — настройка и подключение

Роутер Билайн Smart Box предназначен для подключения пользователей к домашнему интернету. Он позволяет абонентам пользоваться высокоскоростным интернетом и посещать любимые порталы и сайты, находясь в любой части собственной квартиры.

Следует учитывать, что использование устройства требует наличие домашнего интернета. Вставить в прибор сим-карту не получится, поскольку в нем не предусмотрено соответствующего слота. Зато имеется ряд дополнительных функций, делающих оборудование универсальным.

Отдельного рассмотрения заслуживает настройка техники. Производитель сделал ее максимально простой и доступной, чтобы установить соединение сумел любой человек, независимо от умений и знаний.

Начать обзор оборудования следует с базовых характеристик, описывающих технические особенности устройства. Абонентам следует знать, что.

  • максимальная скорость передачи информации достигает 1000 Мбит в секунду;
  • прибор оснащен 4 слотами LAN и 2 портами для USB;
  • для включения техники предусмотрен блок питания, работающий в обычной электросети;
  • оборудование поддерживает все существующие сейчас стандарты wi-fi.

Дополнительно в устройство встроена функция поддержки IPTV. В результате клиенты способны подключать интерактивное телевидение без покупки дополнительных приставок, поскольку процесс настройки телетрансляций предельно прост и не вызовет у них затруднений.

Любопытно подчеркнуть, что производитель роутера Smart Box – Билайн, а потому и приобретать прибор рекомендуется в точках продаж телефонной компании.

При выборе второго способа допускается самовывоз оборудования из выбранного абонентом салона или доставка курьером. Доставка окажется платной, цена зависит от места проживания клиента.

Стоит подчеркнуть, что желающие способны купить описываемую модель в кредит. При этом номинальная стоимость техники – 3900 рублей. При оформлении кредита она незначительно увеличится.

Важным условием использования техники и подключения к интернету станет подготовка оборудования к работе. Настраивать роутер несложно, но пользователям следует предварительно ознакомиться с инструкцией, исключающей даже минимальную вероятность совершения ошибки.

При этом в большинстве случаев все требуемые действия уже произведены разработчиками, а владельцам оборудования остается лишь включить его и подключиться к нужной сети с помощью логина и пароля.

Обычно изменение настроек для использования услуг другого провайдера не вызывает сложностей, поскольку пользователям приходится изменить несколько пунктов в меню. При этом желательно заранее выяснить точные параметры у обслуживающей компании, чтобы не тратить время позднее. В целом процесс внесения изменений выглядит так.

  1. Нужно открыть веб-интерфейс.
  2. Переключиться на расширенные настройки и выбрать вкладку «другие».
  3. Открыть раздел WAN.
  4. Выбрать в списке сервисов Data.
  5. Тип подключения – routing.
  6. Режим IP – PPPoE.
  7. Ввести логин и пароль на другую сеть, полученный от провайдера.
  8. Поставить галочку на пункте «использовать NAT».
  9. Сохранить параметры.
  1. Подключить кабель в порт WAN.
  2. Включить роутер.
  3. Включить компьютер или ноутбук и подключить wi-fi.
  4. Нажать на значок интернета в правом нижнем углу рабочего стола.
  5. Найти в списке доступных сетей подходящую.
  6. Нажать кнопку «подключить».
  7. Ввести ключ безопасности сети в открывшемся поле.
  8. Проверить соединение, открыв любой сайт в браузере.

Последний нюанс, в котором осталось разобраться, связан с установкой обновлений. Узнать актуальную версию прошивки можно на официальном сайте телефонной компании. Если требуется обновление, останется.

  1. Скачать файл с сайта провайдера.
  2. Открыть меню роутера.
  3. Найти уже упомянутый пункт «Другие» в расширенных настройках.
  4. Открыть раздел с упоминанием обновления.
  5. Указать путь к скачанному файлу.
  6. Запустить процесс прошивки.

Роутер Smart Box

Как настроить роутер Билайн smart box под МТС

Вы стали абонентом телевидения и интернета Билайн в Саратове, подключившись по акции «Дом 21 века+» и вам в квартиру в день подключения принесли Wi-Fi роутер Smart Box. Как правило всю настройку оборудования осуществляет монтажник при подключении. Бывают ситуации, когда по каким то причинам настройки вашего роутера сбились и вам необходимо перенастроить ваш Smart Box. Для этого ниже представлена инструкция.

Вставьте кабель, проведеный в квартиру нашими монтажниками в WAN порт, а сетевую карту компьютера соедините патч-кордом (кабелем) из комплекта роутера в любой из портов LAN. Так же можно соединить ваш компьютер с роутером по сети Wi-Fi, но на первом этапе все-таки лучше использовать подключение по кабелю.

Итак, вы подключили роутер к компьютеру и к кабелю из подъезда. Далее откройте ваш браузер и введите в адресную строку 192.168.1.1. Вы должны будете попасть на страницу приветствия. Нажмимайте на кнопку Продолжить.

Программа настройки предложит ввести имя пользователя и пароль. Введите в первое поле admin, и во второе admin. Нажмите Продолжить.

«Домашний Интернет» — в этом разделе происходит настройка соединения с интернето, все данные, которые необходимы для подключения содержатся в памяти устройства, вам только необходимо ввести ваш логин и пароль из договора в соответствующие графы.

«Wi-Fi-сеть роутера» — в этом разделе вы имеете возможность настроить беспроводную домашнюю Wi-Fi сеть. В поле Имя сети необходимо придумать и ввести имя вашей сети, например free_wifi, а в графу пароль введите ключ сети для того чтобы защитить ваше подключение от не санкционированного доступа. Обратите внимание, ключ сети должен быть от 8 символов включая на выбор цифры и буквы латинского алфавита.

«Билайн» ТВ — если вы так же являетесь абонентом телевидения Билайн ТВ, вам необходимо выбрать порт (LAN1, LAN2, LAN3, LAN4), к которому вы подключите приставку. В том случае, если вы просматриваете каналы на ПК или с помощью Xbox 360, настраивать проброс портов не нужно.

Как только соединение будет установлено, напротив строки Статус появится сообщение «Интернет подключен». Примите поздравления! Роутер Smart Box полностью настроен для работы в сети Билайн.

Появится страница с расширенными настройками роутера. В меню слева, нажмите Обновление ПО. Нажимайте на кнопку Выберите файл и с помощью обзора выберите расположение скаченного файла. Далее можете нажать кнопку Выполнить обновление.

Подождите пока устройство выполнит обновление прошивки, это занимает около 5 минут, после этого роутер нужно перезагрузить (вытащить и вставить обратно кабель питания роутера). Ваш Smart Box готов к работе.

Настройка оборудования

В качестве примера, я рассмотрю настройку PPPoE на Смарт Бокс для Ростелеком, ТТК или Дом. ру. В этом случае в строке «Режим IP ставим флажок «PPPoE».
Ниже вводим логин и пароль на доступ, выданные Вам провайдером.
Триггер оставляем в значении Keep Alive для постоянного поддержания соединения активным. MTU так же оставляем по-умолчанию 1460.
Обязательно проверьте чтобы стояла галочка «Использовать NAT и нажимаем кнопку «Сохранить». Внимание! В последних версиях прошишки роутера СмартБокс для суперюзера надо использовать в качестве пароля серийный номер устройства.

Он указан в наклейке, на задней части корпуса, под штрих кодом. Есть роутер билайн и приставка, возможно это все подключить к другому провайдеру что бы смотреть билайновскую приставку?

Но. Если мы входим в веб-интерфейс роутера из-под просто админа — логин = admin; пароль — admin, тогда нам предоставляются настройки, ограниченные провайдером Билайн. В роутере есть USB порт. К роутеру вы можете подключить флешку или внешний жесткий диск, для предоставления общего доступа к ним по сети, а также некоторые USB-модемы.

  • Адрес роутера: 192.168.1.1
  • Доступ в web-интерфейс: логин = admin; пароль — admin
  • Актуальная версия прошивки:v2.0.29 (SmartBox2029.img)
  • Режимы работы: DHCP-клиент, Static IP, PPPoE, L2TP, 3G
  • Wi-Fi: 802.11b/g/n 300Mbps, 2.4GHz, Гостевая Wi-Fi сеть
  • WAN/LAN: WAN — 1 Fast Ethernet, LAN — 4 Fast Ethernet
  • USB-порт: Да, 1 — USB 2.0 (FTP-сервер, Сетевой файловый сервер (Samba), Media Server).
  • Поддержка IPTV: Да, Выделенный LAN-порт и IGMP proxy
  • Прочее: работа в режимах «Точка доступа (AP)» или «Повторитель (Wi-Fi Repeater)»

Beeline Smart Box – брендовый роутер провайдера Beeline изначально предназначенный для работы только в сетях Beeline. Сам роутер производится компанией Sercomm в Тайвани по заказу компании Beeline. В основе роутера лежит референс-плата на основе Realtek 8197D.

В роутере имеется поддержка IPTV и возможность использовать его как сетевое хранилище.

Возможности роутера «Билайн Smart Box и его настройка

Лучше всего перед обновлением прошивки выполнить сброс настроек. Включаем роутер, ждем 2 минуты, нажимаем скрепкой на reset (кнопку надо удерживать 10-15 секунд). Светодиоды должны мигнуть, затем, роутер загрузится снова (но уже с настройками «по умолчанию»).

Устанавливать прошивку мы будем, подключив роутер к ПК по проводной сети. Это – обязательно. Переустановку программного обеспечения выполняют с единственной целью: чтобы избавить роутер от «багов предыдущей прошивки. Если все хорошо работает, ничего переустанавливать не надо. Мы рассмотрим, как настроить соединение с провайдером «Билайн».

Подключить к роутеру компьютер для этого можно через патч-корд или по беспроводной сети (которая работает в смешанном режиме b/g/n, ей присвоено имя «Smart_box-…»). В завершение будет рассмотрено, как обновить фирменную прошивку. Версия прошивки, актуальная на момент создания обзора – 2.0.19.

Билайн Smart Box

Роутер предложит вам ввести имя пользователя и пароль. Введите в первое поле admin, во второе также admin. Нажмите кнопку Продолжить.

Подключите кабель, который вам провели в квартиру наши монтажники в порт WAN, а компьютер подключите в любой из LAN портов. Вы также можете соединить ваш ПК с роутером по беспроводной сети, но на первичном этапе настройки лучше использовать кабель.

Откройте браузер и введите в адресную строку 192.168.1.1. Вы попадете на страницу приветствия. Нажмите кнопку Продолжить.

Нажмите кнопку «Выберите файл и укажите расположение файла с прошивкой, который вы скачали ранее.

А вы хорошо знаете статическую маршрутизацию?

Статический маршрут — первое, с чем сталкивается любой человек при изучении понятия маршрутизации IP пакетов. Считается, что это — наиболее простая тема из всех, в ней всё просто и очевидно. Я же постараюсь показать, что даже настолько примитивная технология может содержать в себе множество нюансов.

Оговорка. При написании топика я исхожу из того, что читатель знаком с концепцией маршрутизации, умеет делать статические маршруты и не считает слово «ARP» ругательным. Впрочем, даже бывалые связисты наверняка найдут тут что-то новое.
Все примеры были проверены на IOS линейки 15.2M. Поведение других ОС может различаться.
И никакого динамического роутинга тут не будет.

Мы работаем со следующей топологией:

Как появляется статический маршрут?

Для начала, выполним команду, которую знает каждый, и посмотрим дебагами, что произойдет:

R00(config)#ip route 3.1.1.0 255.255.255.0 10.0.0.3
IP-ST(default): updating same distance on 3.1.1.0/24 IP-ST(default): 3.1.1.0/24 [1], 10.0.0.3 Path = 8, no change, not active state IP-ST(default): 3.1.1.0/24 [1], 10.0.0.3 Path = 2 3 7 RT: updating static 3.1.1.0/24 (0x0): via 10.0.0.3 RT: add 3.1.1.0/24 via 10.0.0.3, static metric [1/0], add succeed, active state IP ARP: creating incomplete entry for IP address: 10.0.0.3 interface GigabitEthernet0/1 IP ARP: sent req src 10.0.0.1 30e4.db16.7791, dst 10.0.0.3 0000.0000.0000 GigabitEthernet0/1 IP ARP: rcvd rep src 10.0.0.3 0019.aad6.ae10, dst 10.0.0.1 GigabitEthernet0/1

IOS создал маршрут, и сразу послал arp запрос в поисках next hop, который у нас – 10.0.0.3. И сразу вопрос: откуда роутер узнал, что запрос надо слать в интерфейс Gi0/1? Наверняка кто-то скажет «из списка локальных интерфейсов», и жестоко ошибется. Маршрутизация так не работает. На самом деле, IOS сделал рекурсивный запрос к таблице маршрутизации, чтобы узнать, как добраться до next hop:

R00#show ip route 10.0.0.3 Routing entry for 10.0.0.0/24 Known via "connected", distance 0, metric 0 (connected, via interface) Routing Descriptor Blocks: * directly connected, via GigabitEthernet0/1 Route metric is 0, traffic share count is 1

И вот он, наш Gi0/1. IOS узнает, что с рекурсивными запросами к RIB надо заканчивать, как только находит маршрут с флагом «directly connected». Но что если ему в ответ на изначальный запрос к 10.0.0.3 вернется вовсе не connected маршрут, а промежуточный, ссылающийся на другой next hop? Вернемся к этому чуть позже, а пока вспомним, что такое CEF.

Примерно во всей документации, ориентированной на начинающих, говорится, что каждый пакет перемещается в соответствии с таблицей маршрутизации. На самом деле на всех более-менее современных платформах это уже не так, ведь таблица маршрутизации (далее – RIB) вовсе не оптимизирована для быстрой передачи данных. Оценить масштаб бедствия позволяет эта таблица (хотя у process switching’а множество недостатков помимо неоптимальных запросов – например, постоянное переключение шедулера CPU между контекстами, что весьма затратно). CEF является серьезной оптимизацией. В современной реализации он строит две таблицы – FIB (Forwarding Information Base, таблица передачи пакетов, в основе нее – связный граф со страшным названием 256-way mtrie) и adjacency table (таблица соседств). Первая из них строится на основе таблицы маршрутизации и за один проход позволяет получить всю нужную информацию. Строится она заранее, еще до того, как появится первый соответствующий ей пакет.

Вернемся к нашему статическому маршруту. Вот запись в таблице маршрутизации:

R00#show ip route 3.1.1.0 Routing entry for 3.1.1.0/24 Known via "static", distance 1, metric 0 Routing Descriptor Blocks: * 10.0.0.3 Route metric is 0, traffic share count is 1

Куда слать пакет? Где искать 10.0.0.3? Непонятно. Надо еще раз запросить таблицу маршрутизации, на этот раз по поводу 10.0.0.3, и, если надо, выполнить еще несколько итераций, пока не выясним connected интерфейс. И вот примерно таким образом мы фактически в несколько раз снижаем производительность маршрутизатора.

А вот что говорит CEF:

R00#show ip cef 3.1.1.0 detail 3.1.1.0/24, epoch 0 recursive via 10.0.0.3 attached to GigabitEthernet0/1

Просто и лаконично. Есть интерфейс, есть next hop, к которому надо слать пакет. Что там говорилось про adjacency table?

R00#show adjacency 10.0.0.3 detail Protocol Interface Address IP GigabitEthernet0/1 10.0.0.3(10) 0 packets, 0 bytes epoch 0 sourced in sev-epoch 2 Encap length 14 0019AAD6AE1030E4DB1677910800 ARP

Обратим внимание на какую-то длинную последовательность в предпоследней строке. Что-то это напоминает… Смотрим mac 10.0.0.3:

R00#show arp | in 10.0.0.3 Internet 10.0.0.3 1 0019.aad6.ae10 ARPA GigabitEthernet0/1

Смотрим свой mac адрес на gi0/1:

R00#show int gi0/1 GigabitEthernet0/1 is up, line protocol is up Hardware is CN Gigabit Ethernet, address is 30e4.db16.7791 (bia 30e4.db16.7791)

Ага. Та страшная строка – всего лишь два мака, которые надо подставить в заголовок Ethernet на этапе инкапсуляции, и ethertype 0x0800, т.е. банальный IPv4. И в двух таблицах CEF есть абсолютно вся информация, какая нужна для успешной отправки пакета дальше по цепочке.

Если у кого-то возникнет вопрос, зачем железке держать сразу две таблицы вместо одной, то дам очевидный ответ: обычно у маршрутизатора мало интерфейсов (а заодно и соседей) и много маршрутов. Какой смысл тысячи раз дублировать одни и те же маки в FIB? Памяти много не бывает, особенно на аппаратных платформах, будь то новомодные ASR’ы или даже L3 свитчи линейки Catalyst. Все они задействуют CEF при передаче пакетов.

И кстати, вернемся на минутку к изначальному дебагу. Отключим CEF командой no ip cef (никогда так не делайте) и сравним результат:

IP-ST(default): updating same distance on 3.1.1.0/24 IP-ST(default): 3.1.1.0/24 [1], 10.0.0.100 Path = 8, no change, not active state IP-ST(default): 3.1.1.0/24 [1], 10.0.0.100 Path = 2 3 7 RT: updating static 3.1.1.0/24 (0x0): via 10.0.0.100 RT: add 3.1.1.0/24 via 10.0.0.100, static metric [1/0], add succeed, active state

Маршрут добавлен. Arp запроса не было. И правильно – зачем RIB сдался mac адрес? Если пустить пинг до, к примеру, 3.1.1.1, то скорее всего будет так:

R00#ping 3.1.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 3.1.1.1, timeout is 2 seconds: . Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms

Первый пакет отбрасывается, и роутер посылает arp запрос с целью узнать mac адрес 10.0.0.3, если он ранее не был известен. CEF же всегда заранее узнает mac адрес next hop’а.

С этим разобрались. Теперь вернемся к вопросу, что будет, если next hop статического маршрута вовсе не на directly connected интерфейсе. Поступим просто:

R00(config)#ip route 10.0.0.3 255.255.255.255 100.100.100.101

, где Gi0/2 имеет адрес 100.100.100.100/24.

R00#show ip cef 3.1.1.0 detail 3.1.1.0/24, epoch 0 recursive via 10.0.0.3 recursive via 100.100.100.101 recursive via 100.100.100.0/24 attached to GigabitEthernet0/2

Как все плохо-то… А что если у нас есть маршрут на целую суперсеть?

R00(config)#no ip route 10.0.0.3 255.255.255.255 100.100.100.101 R00(config)#ip route 10.0.0.0 255.0.0.0 100.100.100.101 R00#show ip cef 3.1.1.0 detail 3.1.1.0/24, epoch 0 recursive via 10.0.0.3 attached to GigabitEthernet0/1

Сейчас наша таблица маршрутизации выглядит так:

R00#show ip route 10.0.0.0/8 is variably subnetted, 2 subnets, 3 masks S 10.0.0.0/8 [1/0] via 100.100.100.101 C 10.0.0.0/24 is directly connected, GigabitEthernet0/1 L 10.0.0.1/32 is directly connected, GigabitEthernet0/1 100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks C 100.100.100.0/24 is directly connected, GigabitEthernet0/2 L 100.100.100.100/32 is directly connected, GigabitEthernet0/2

Вроде хорошо. Новый маршрут на 100.100.100.101 не применяется для 10.0.0.3, так как его маска /8 намного короче, чем /24 у connected интерфейса. Но вдруг Gi0/1, содержавший next hop для 3.1.1.0/24, по какой-то непонятной причине ушел в down, и его connected маршрут пропал из RIB.

%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to administratively down %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down RT: interface GigabitEthernet0/1 removed from routing table RT: del 10.0.0.0 via 0.0.0.0, connected metric [0/0] RT: delete subnet route to 10.0.0.0/24 RT: del 10.0.0.1 via 0.0.0.0, connected metric [0/0] RT: delete subnet route to 10.0.0.1/32 IP-ST(default): updating GigabitEthernet0/1

Вот что стало:

R00#show ip cef 3.1.1.0 detail 3.1.1.0/24, epoch 0 recursive via 10.0.0.3 recursive via 10.0.0.0/8 recursive via 100.100.100.101 recursive via 100.100.100.0/24 attached to GigabitEthernet0/2

Ой. Теперь пакеты на сеть 3.1.1.0/24 идут куда-то не туда. Я не могу представить себе сценарий, когда ожидаемое поведение статического маршрута – переключение на другой интерфейс. Если за тем интерфейсом находится резервный путь, то все-таки надо создавать еще один статический маршрут…

Что делать? Указывать сразу в маршруте интерфейс. Пересоздадим маршрут:

R00(config)#no ip route 3.1.1.0 255.255.255.0 10.0.0.3 R00(config)#ip route 3.1.1.0 255.255.255.0 Gi0/1 10.0.0.3

Поднимаем Gi0/1. Смотрим, куда теперь ведет маршрут на 3.1.1.0/24:

R00#show ip route 3.1.1.0 Routing entry for 3.1.1.0/24 Known via "static", distance 1, metric 0 Routing Descriptor Blocks: * 10.0.0.3, via GigabitEthernet0/1 Route metric is 0, traffic share count is 1

Тут уже указан интерфейс. Поэтому не будет рекурсивных запросов к таблице маршрутизации. Проверяем FIB:

R00#show ip cef 3.1.1.0 3.1.1.0/24 nexthop 10.0.0.3 GigabitEthernet0/1

Да, никакого «recursive». А если снова погасить gi0/1? Маршрут исчез.

R00#show ip route 3.1.1.0 % Network not in table R00#show ip cef 3.1.1.0 0.0.0.0/0 no route

И это притом, что маршрут до 10.0.0.3 все еще был:

R00#show ip cef 10.0.0.3 10.0.0.0/8 nexthop 100.100.100.101 GigabitEthernet0/2

А что будет, если путь к next hop даст маршрут по умолчанию, а маршрут на 3.1.1.0/24 не ссылается на интерфейс?

R00(config)#no ip route 10.0.0.0 255.0.0.0 100.100.100.101 R00(config)#ip route 0.0.0.0 0.0.0.0 100.100.100.101 R00(config)#no ip route 3.1.1.0 255.255.255.0 Gi0/1 10.0.0.3 R00(config)#ip route 3.1.1.0 255.255.255.0 10.0.0.3 R00#show ip route 3.1.1.0 % Network not in table R00#show ip cef 3.1.1.0 detail 0.0.0.0/0, epoch 0, flags default route recursive via 100.100.100.101 recursive via 100.100.100.0/24 attached to GigabitEthernet0/2

Обратите внимание, что первой строкой после «show ip cef» идет «0.0.0.0/0», а не «3.1.1.0/24». Несмотря на то, что next hop формально есть, по факту все итерации опроса таблицы маршрутизации (кроме первой) игнорируют маршрут по умолчанию, что логично, иначе любой запрос к таблице маршрутизации почти всегда бы резолвился (под «резолвиться» понимается нахождение интерфейса, в который нужно отправить пакет). Поэтому наш статический маршрут отсутствует, но пакеты все равно улетают к Gi0/2. Вроде бы все то же самое, что и без явного указания интерфейса? Не совсем. Допустим, протоколу маршрутизации сказали «redistribute static». Если статический маршрут пропал, то анонс тоже отзывается. А если нет, то маршрутизатор продолжит говорить всем «туда идти через меня», и это почти наверняка обернется L3 кольцом для префикса 3.1.1.0/24, который мог бы быть доступен откуда-нибудь еще. Но стоп, мы договаривались не трогать динамический роутинг…

А что если в статическом маршруте указать интерфейс, но не указывать IP адрес следующего хопа? Ответ: в случае Ethernet, если на next hop не отключен proxy arp, связность не нарушится, но роутеру может ОЧЕНЬ поплохеть. Подробнее. Если сказать «ip route 3.1.1.0 255.255.255.0 gi0/1», то ничего особо страшного не случится, даже пару сотен записей в arp таблице любой роутер переварит (и существуют сценарии-workaround’ы, в которых оптимальным решением является именно такой костыль), но вот «ip route 0.0.0.0 0.0.0.0 gi0/1» на пограничном маршрутизаторе наверняка убьет его. Потому запомните общее правило: если создается статический маршрут с next hop’ом на Ethernet интерфейсе, то его IP адрес должен указываться всегда. Исключения – только когда вы очень хорошо представляете себе, что делаете, зачем делаете и почему нельзя сделать иначе.

И напоследок, сделаем одну очень нехорошую штуку.

R00(config)# ip route 3.1.1.0 255.255.255.0 10.0.0.3 R00(config)#ip route 10.0.0.3 255.255.255.255 3.1.1.1

Первый маршрут в порядке, сто раз протестирован. А вот второй странный – он ведет через первый. А первый теперь ссылается на второй, и у нас бесконечная рекурсия. Вот что произошло:

IP-ST(default): updating same distance on 3.1.1.0/24 IP-ST(default): 3.1.1.0/24 [1], 10.0.0.3 Path = 8, no change, not active state IP-ST(default): 3.1.1.0/24 [1], 10.0.0.3 Path = 2 3 7 RT: updating static 3.1.1.0/24 (0x0): via 10.0.0.3 RT: add 3.1.1.0/24 via 10.0.0.3, static metric [1/0], add succeed, active state IP-ST(default): updating same distance on 10.0.0.3/32 IP-ST(default): 10.0.0.3/32 [1], 3.1.1.1 Path = 8, no change, not active state IP-ST(default): 10.0.0.3/32 [1], 3.1.1.1 Path = 2 3 7 RT: updating static 10.0.0.3/32 (0x0): via 3.1.1.1 RT: add 10.0.0.3/32 via 3.1.1.1, static metric [1/0], add succeed, active state

Добавилось успешно. Но затем в дебагах высветилось:

RT: recursion error routing 3.1.1.1 - probable routing loop RT: recursion error routing 10.0.0.3 - probable routing loop

И появилась запись в лог с severity 3:

%IPRT-3-RIB_LOOP: Resolution loop formed by routes in RIB
R00#show ip cef 10.0.0.3 detail 10.0.0.3/32, epoch 0 Adj source: IP adj out of GigabitEthernet0/1, addr 10.0.0.3 359503C0 Dependent covered prefix type adjfib cover 10.0.0.0/24 1 RR source [no flags] recursive via 3.1.1.1, unresolved recursive-looped R00#show ip cef 3.1.1.0 detail 3.1.1.0/24, epoch 0, flags cover dependents Covered dependent prefixes: 1 notify cover updated: 1 recursive via 10.0.0.3, unresolved recursive-looped

Однако, RIB никакого криминала не видит:

Routing entry for 3.1.1.0/24 Known via "static", distance 1, metric 0 Routing Descriptor Blocks: * 10.0.0.3 Route metric is 0, traffic share count is 1 R00#show ip route 10.0.0.3 Routing entry for 10.0.0.3/32 Known via "static", distance 1, metric 0 Routing Descriptor Blocks: * 3.1.1.1 Route metric is 0, traffic share count is 1

Вывод – никогда так не делайте.

Почему статический маршрут может не попасть в таблицу маршрутизации?

Любой сетевик должен сходу дать одно из объяснений, касающееся любого источника маршрутов в IOS: существует другой маршрут на тот же самый префикс, но с меньшим AD (все помнят Administrative Distance?). Маршрут, источник которого – “connected”, всегда имеет AD=0, и ни один другой источник маршрутов не может привнести ничего ниже, чем «1», даже статический маршрут с явным указанием интерфейса. Пример connected:

R00# show ip route C 10.0.0.0/24 is directly connected, GigabitEthernet0/1

Т.е. пока интерфейс Gi0/1 находится в состоянии up и имеет адрес из подсети 10.0.0.0/24, ни один статический маршрут на этот префикс в таблице маршрутизации не появится.

Еще есть вариант «разные источники маршрутов добавляют маршруты на один и тот же префикс с одинаковым AD». Поведение IOS в данном случае не документировано, общая рекомендация – «никогда так делайте».

Но посмотрим другие, менее очевидные примеры. Например, статические маршруты можно создать со словом «permanent», которое переводится как «постоянный», и тогда они будут всегда висеть в таблице маршрутизации. Правильно? Нет.

Добавляем его и смотрим:

R00(config)#ip route 3.1.1.0 255.255.255.0 10.0.0.3 permanent R00#show ip cef 3.1.1.0 3.1.1.0/24 nexthop 10.0.0.3 GigabitEthernet0/1

Кладем Gi0/1, и видим:

R00#show ip cef 3.1.1.0 3.1.1.0/24 unresolved via 10.0.0.3

В RIB он есть, и другие протоколы маршрутизации могут его использовать:

R00#show ip route 3.1.1.0 Routing entry for 3.1.1.0/24 Known via "static", distance 1, metric 0 Routing Descriptor Blocks: * 10.0.0.3, permanent Route metric is 0, traffic share count is 1

А теперь, не поднимая Gi0/1:

R00(config)#no ip route 3.1.1.0 255.255.255.0 10.0.0.3 permanent R00(config)#ip route 3.1.1.0 255.255.255.0 10.0.0.3 permanent

Просто пересоздали его, ничего не меняя. И вот что произошло:

IP-ST(default): updating same distance on 3.1.1.0/24 IP-ST(default): 3.1.1.0/24 [1], 10.0.0.3 Path = 8, no change, not active state IP-ST(default): cannot delete, PERMANENT R00#show ip route 3.1.1.0 % Network not in table R00#show ip cef 3.1.1.0 0.0.0.0/0 no route

Постоянный, говорите? Нет. Есть один маленький нюанс: чтобы перманентный маршрут навеки вписался в таблицу маршрутизации, нужно, чтобы он хотя бы на долю секунды резолвился. Хотя какое еще «навеки»? Когда он остался висеть в воздухе без резолвящегося интерфейса, достаточно сказать «clear ip route *» или тем более «reload», чтобы он исчез из RIB.

Но продолжим. Сделаем вот так:

R00(config)#ip route 3.1.1.0 255.255.255.0 Gi0/1 10.0.0.3 R00(config)#ip route 3.1.1.10 255.255.255.255 3.1.1.1

Вроде нормальные маршруты. Что произойдет? Со вторым – ровным счетом ничего.

IP-ST(default): 3.1.1.10/32 [1], 3.1.1.1 Path = 8, no change, not active state IP-ST(default): 3.1.1.10/32 [1], 3.1.1.1 Path = 2 3 6 8, no change, not active state

Суть вот в чем. Допустим, есть маршрут на X.X.X.X через Y.Y.Y.Y. Мы добавляем маршрут на X1.X1.X1.X1 (этот префикс полностью покрывается X.X.X.X) через X2.X2.X2.X2 (а он тоже покрывается X.X.X.X). IOS делает закономерный вывод: второй маршрут не несет в себе никакой новой информации и совершенно бесполезен, поэтому его можно не устанавливать в RIB.

А теперь финт ушами.

R00(config)#no ip route 3.1.1.10 255.255.255.255 3.1.1.1 R00(config)#ip route 3.1.1.10 255.255.255.255 Gi0/1 3.1.1.1 IP-ST(default): updating same distance on 3.1.1.10/32 IP-ST(default): 3.1.1.10/32 [1], GigabitEthernet0/1 Path = 1 RT: updating static 3.1.1.10/32 (0x0): via 3.1.1.1 Gi0/1 RT: network 3.0.0.0 is now variably masked RT: add 3.1.1.10/32 via 3.1.1.1, static metric [1/0], add succeed, active state IP ARP: creating incomplete entry for IP address: 3.1.1.1 interface GigabitEthernet0/1 IP ARP: sent req src 10.0.0.1 30e4.db16.7791, dst 3.1.1.1 0000.0000.0000 GigabitEthernet0/1 R00#show ip cef 3.1.1.10 3.1.1.10/32 nexthop 3.1.1.1 GigabitEthernet0/1 

И вот это подводит нас к еще одному важному моменту. Указание интерфейса в статическом маршруте позволяет обойти многие проверки, так как статическому маршруту больше не требуется выполнять рекурсивные запросы к RIB в поисках пути до next hop, и при своем добавлении он не заденет триггеры на других маршрутах. Но это не отменяет главного требования: next hop обязан резолвиться в конкретный интерфейс, а тот интерфейс обязан быть в up. Тот факт, что рекурсивных запросов к RIB больше не будет, означает, что указанный IP адрес next hop’а находится прямо за интерфейсом, и наверняка отзовется на arp запрос (с точки зрения роутера). Если у соседнего по Gi0/1 роутера включен proxy arp, то он в ответ на arp запрос наверняка вернет свой mac адрес, и всё будет хорошо. Разве что лишняя запись в arp таблице…

Но все равно так делать не стоит.

Необходимо упомянуть и о еще одном важном моменте. Статический маршрут должен по идее исчезнуть из таблицы маршрутизации, как только он перестанет резолвиться. Но на практике есть множество ситуаций, когда next hop пропадает, но при этом статический маршрут на какое-то время остается. К примеру, когда next hop резолвится через маршрут, полученный от протокола динамической маршрутизации. Все дело в том, что процесс, отслеживающий наличие next hop в RIB, не всегда может получить уведомление об исчезновении маршрута, и он вынужден периодически (раз в 60 секунд по умолчанию) перепроверять, все ли хорошо. Это вызовет заметную задержку сходимости сети.

Поменять интервал проверки, к примеру, на 10 секунд можно с помощью команды:

ip route static adjust-time 10

Что такое rout и rep на роутере

Cisco announces AI innovation and partnerships at Cisco Live Amsterdam

AI in Cisco Security Cloud

Cisco’s pioneering identity intelligence to defend against identity-based attacks.

Innovations in Full-Stack Observability

Cisco unveils a series of new capabilities on the Cisco Observability Platform

Cisco launches Motific

Cisco’s first SaaS product that allows for trustworthy generative AI

Growing the networking cloud vision

Cisco adds greater insight and intelligence to its networking platform portfolio.

Cisco AI Assistant for Webex

Cisco’s responsible AI helps improve collaboration in the hybrid workplace.

Webex for Apple Vision Pro

Webex is unleashing the new era of spatial computing to elevate hybrid work.

Cisco Success Tracks expansion

Cisco CX is accelerating outcomes through technology innovation.

New AI in Cisco Cloud Application

Outshift by Cisco announces one of the first context-aware AIs: Cisco AI Assistant for Panoptica.

Integrated visibility from ThousandEyes

Gain Cisco Secure Access Experience Insights, powered by ThousandEyes.

Connecting and protecting Super Bowl LVIII

Every day is game day for the National Football League. That’s why the NFL relies on Cisco to connect and protect its teams, stadiums and events, including Super Bowl LVIII.

Cisco AI Assistant

More data. Better intelligence. Infinite possibilities.

Cisco AI Assistant accesses an extensive amount of data to help you work faster, safer, and smarter.

The power of purpose

We combine our technology, people, and broader networks to address society’s greatest challenges. Since FY16, Cisco has made a positive impact on more than 1 billion lives.

Stopping attackers is simpler than ever

From the network to the cloud, respond quickly and confidently to the most sophisticated cyberattacks.

Inside Cisco

NVIDIA GTC

Join Cisco at NVIDIA’s leading AI event.

Cisco EVP Liz Centoni’s 7 tech trends for 2024

Advancements in AI are leading to a once-in-a-generation shift. This shift is presenting new opportunities and transforming industries, modes of operation, and career paths.

CPFL Energia wins award for securing network with Cisco IoT solutions

Brazilian power utility was recognized with the National Security Leaders of 2023 award for securing grid operations with Cisco Cyber Vision, built into Cisco industrial switches.

Что такое rout и rep на роутере

Repiter

У меня появилась задача расширить зону покрытия моей домашней wifi-сети. Создает ее роутер от ASUS (потому что с ADSL), расширяет до текущих масштабов тоже ASUS. Дальнейшее расширение я захотел сделать на mikrotik, заодно попытаться второй ASUS заменить так же на mikrotik. Первый бы тоже заменил, но не нашел у микротиков чего-либо для работы с ADSL. До недавнего времени сделать это было нельзя.

Можно было либо:

В итоге проблема решилась обновлением routeros до версии 6.35. В ней добавили модуль wireless-rep, который позволяет реализовать желаемое, а так же получить некоторые приятные бонусы. Например, из минироутеров ( mAP или RB941-2nD-TC) можно сделать фильтр wifi сети для путешествий.

Я люблю консоль, поэтому все инструкции будут для нее. Аналогии в winbox или веб-интерфейсе достаточно прозрачны.

Обновление до RouterOS 6.35.

На данный момент эта версия в стадии Release Candidate, поэтому этот пункт имеет смысл. Как только 6.35 станет стабильной — данный пункт можно смело пропускать.

Штатно обновляемся до последней стабильной версии RouterOS. Далее ставим канал обновлений на release-candidate:

/system package update set channel=release-candidate

/system package update install

Пока роутер перезагружается, качаем отсюда архив extra packages для новой версии RouterOS. Из него нас интересует файл, содержащий в названии wireless-rep. Заливаем его на наш роутер и перезагружаем роутер еще раз.

После перезагрузки проверяем, что модуль wireless-rep появился в списке пакетов и активен:

/system package print

Flags: X - disabled # NAME - VERSION SCHEDULED 0 routeros-mipsbe - 6.35rc45 1 system - 6.35rc45 2 X wireless-cm2 - 6.35rc45 3 X ipv6 - 6.35rc45 4 X wireless-fp - 6.35rc45 5 X hotspot - 6.35rc45 6 dhcp - 6.35rc45 7 mpls - 6.35rc45 8 routing - 6.35rc45 9 ppp - 6.35rc45 10 security - 6.35rc45 11 advanced-tools - 6.35rc45 12 X multicast - 6.35rc45 13 wireless-rep - 6.35rc45

Настройка собственно репитера

Короткий путь для ленивых

/interface wireless setup-repeater number=wlan1 ssid=My_WIFI passphrase=TheBestPassword

Что делает эта команда?

  • сбрасывает настройки мастер-интерфейса (wlan1 в нашем случае) (так же как делает reset-configuration)
  • убирает виртуальные интерфейсы, привязанные к этому мастер-интерфейсу из всех возможных бриджей (чтоб не оставлять записей об ошибочных портах бриджей)
  • удаляет все виртуальные интерфейсы данного мастер-интерфейса
  • создает security profile «interfacename-ssid-repeater», если такой security profile уже существует, то не создает новый, а обновляет настройки старого
  • настраивает мастер-интерфейс, режим работы выбирается следующим образом: если точка доступа (вышестоящая) поддерживает режим работы bridge (это проприетарный режим работы mikrotik, поэтому только с ними), используется station-bridge, иначе если точка доступа поддерживает WDS, используется station-wds, иначе используется station-pseudobridge (наш случай)
  • создает интерфейс virtualAP с таким же SSID и security profile как и мастер
  • если мастер-интерфейс не состоит ни в каком бридже, создает новый бридж и добавляет мастер-интерфейс в него
  • добавляет интерфейс virtual AP в тот же бридж, что и мастер.

Длинный путь для дотошных

Настраиваем security-profile для нашей wifi сети:

/interface wireless security-profiles add name=MyTestWIFI-repeater mode=dynamic-keys authentication-types=wpa2-psk unicast-ciphers=aes-ccm group-ciphers=aes-ccm wpa2-pre-shared-key=»MySuperPassword»

Это настройки для WPA2. Если у Вас по каким-то причинам используется другой протокол — Вы, я надеюсь, знаете, что тут писать.

Настраиваем мастер-интерфейс для подключения к нашей wifi сети, как будто мы просто в режиме station, только указываем mode=station-pseudopridge:

/interface wireless set numbers=wlan1 ssid=MyTestWIFI security-profile=MyTestWIFI-repeater mode=station-pseudobridge

Убираем виртуальные интерфейсы, привязанные к этому мастер-интерфейсу из всех возможных бриджей (чтоб не оставлять записей об ошибочных портах бриджей). Тут, надеюсь, если Вы их настроили, Вы же знаете как их убрать.

Удаляем все виртуальные интерфейсы данного мастер-интерфейса.

Создаем интерфейс virtual AP с таким же SSID и security profile как и мастер, но режим работы указываем ap-bridge:

/interface wireless add copy-from=wlan1 name=wlan2 master-interface=wlan1 mode=ap-bridge

Если мастер-интерфейс не состоит ни в каком бридже, создаем новый бридж и добавляет мастер-интерфейс в него:

/interface bridge add name=wifibridge
/interface bridge port add bridge=wifibridge interface=wlan1

Добавляем интерфейс virtual AP в тот же бридж, что и мастер:

/interface bridge port add bridge=wifibridge interface=wlan2

Настройка DHCP-relay

К этому моменту мы должны получить усиленный сигнал нашей wifi-сети. Но у клиентов в зоне действия нашего репитера, перестанут выдаваться автоматически ip-адреса, то есть не будет работать DHCP. Почему? Это из-за того, что к главной точке доступа мы подключаемся в режиме station-pseudobridge, В этом режиме на интерфейсе происходит трансляция MAC-адресов (по аналогии с NAT, только на канальном уровне). То есть для всей остальной сети все устройства, которые подключаются к wifi через репитер имеют один MAC-адрес. Это не страшно, когда IP-адреса статические. Но для работы DHCP надо сделать следующие настройки:

Назначаем бриджу, в который входят наши беспроводные интерфейсы, адрес из основной сети (адреса из которой раздаются по DHCP).

/ip address add address=192.168.1.160/24 interface=wifibridge

Или динамически, включив на нем DHCP-клиент (этот способ рекомендую только в случае, если на основном роутере для репитера прописан постоянный dhcp-lease):

/ip dhcp-client add interface=wifibridge

После включения dhcp-клиента назначенный адрес можно посмотреть так:

/ip address print

Теперь мы можем включить DHCP-relay, который в дополнение к трансляции MAC-адресов будет транслировать DHCP-запросы в основную сеть и обратно:

/ip dhcp-relay add dhcp-server=192.168.1.1 interface=wifibridge local-address=192.168.1.160

где 192.168.1.1 — адрес DHCP-сервера в нашей сети (обычно адрес основного роутера), а 192.168.1.160 — адрес назначенный нашему репитеру.

Теперь наш репитер должен полноценно заработать.

Бонус.

Как я писал выше, используя новый модуль wireless-rep мы можем настроить wifi-фильтр для путешествий. Он будет подключаться к внешней wifi-сети (в гостинице, аэропорту или метро), фильтровать трафик и отдавать во внутреннюю сеть или даже заворачивать внутренний трафик в VPN.

Подробно расписывать не буду, делается по аналогии с написанным выше:

Мастер-wifi-интерфейс (wlan1) убираем из каких-либо бриджей, назначаем ему mode=ap-bridge, ssid внутренней сети и отдельный security-profile.
Создаем дочерний wifi-интерфейс (wlan2), который подключаем к необходимой внешней сети.
Дочерний wifi-интерфейс по желанию объединяем в bridge с ethernet-портами.
Настраиваем masquerade в таблице nat фаервола из внутренней сети во внешнюю.
Настраиваем фильтры в таблице filter фаервола, исключая доступ к роутеру из внешней сети.

В результате, приезжая куда-то где есть wifi, мы подключаемся к роутеру через внутренний wifi, настраиваем на нем внешний wifi и пользуемся сетью, сидя за «каменной стеной».

Участник конкурса Иван Прокудин

Просьба всем кто читает статьи, участвующие в конкурсе, ставить оценки.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *