Что такое rip в роутере
Перейти к содержимому

Что такое rip в роутере

  • автор:

Что такое rip в роутере

Протокол RIP (Routing Information Protocol) основан на дистанционно-векторном алгоритме маршрутизации, в качестве метрики при выборе маршрута использует количество переходов (hops count), т. е. количество маршрутизаторов, которое должен пройти пакет, прежде чем достигнет пункта назначения.

Каждый маршрутизатор, использующий RIP, хранит таблицу, содержащую записи для каждого пункта назначения (сети или узла) в системе. Каждая запись включает следующую информацию:

  • IP address: IP-адрес узла или сети назначения;
  • Gateway: адрес первого транзитного маршрутизатора на пути к пункту назначения;
  • Interface: интерфейс, напрямую подключенный к первому транзитному маршрутизатору;
  • Cost: числовое значение, показывающее расстояние до пункта назначения;
  • Timer: количество времени, прошедшее после последнего обновления записи.

Если маршрутизатор непосредственно подключен к сети, то расстояние до неё (количество переходов) равно 1. Максимальное число переходов — 15. Значение 16 называется бесконечностью (infinity) и означает, что данный узел или сеть недостижима.

Периодически (по умолчанию каждые 30 секунд) маршрутизаторы широковещательно отправляют своим соседям обновления с маршрутной информацией. Обновления (update message) – это набор сообщений, которые содержат часть или всю информацию из таблицы маршрутизации.

При получении обновления от соседа, маршрутизатор увеличивает значение метрики (число переходов) к соответствующей сети на 1. Маршрутизатор, получивший обновление, извлекает из него новую информацию и заносит ее в таблицу маршрутизации. Новой считается информация о маршруте к неизвестной ранее сети или о маршруте к уже известной сети с лучшим значением метрики.

Для каждой записи в таблице маршрутизации существует время старения (Timeout timer), контролируемое таймером (по умолчанию 180 секунд). Таймер старения обнуляется каждый раз, когда маршрутизатор получает обновление с информацией о соответствующем маршруте. Если информация о каком-либо маршруте отсутствует в периодических обновлениях, и время, установленное таймером, истекает, то маршрут помечается как недостижимый (значение метрики устанавливается равным 16).

IP-интерфейсы маршрутизирующих коммутаторов

В отличие от традиционного маршрутизатора, который требует, чтобы каждый порт был подключен в отдельную сеть или подсеть, физическому порту коммутатора D-Link невозможно назначить собственный IP-интерфейс.

Когда узлы из одной сети/подсети подключаются к портам коммутатора L3, эти порты группируются в VLAN. Даже если для подключения используется только один порт коммутатора, он все равно должен быть помещен в VLAN. Для VLAN создается IP-интерфейс и ему присваивается IP-адрес из сети/подсети, к которой принадлежат подключенные узлы. Порты, включаемые в VLAN, не обязательно должны быть расположены последовательно и могут принадлежать разным коммутаторам. IP-интерфейс, назначенный VLAN, может использоваться в качестве шлюза по умолчанию узлами данной сети/подсети.

Примечание к настройке
Рассматриваемый пример настройки подходит для коммутаторов серий DGS-3120, DGS-3420, DGS-3620.
Задача

В сети необходимо обеспечить динамическую маршрутизацию между VLAN. Задача может быть решена настройкой на коммутаторах протокола RIPv2.

Схема сети показана на рисунке 1.

Рис. 1 Схема подключения
Примечание

Не соединяйте порты коммутаторов Ethernet-кабелями до тех пор, пока не настроена маршрутизация. В коммутируемой сети может возникнуть петля.

Настройка коммутатора SW1

  1. Удалите порты из VLAN по умолчанию и создайте новые VLAN:

config vlan default delete 1-4,21-24
create vlan v20 tag 20
create vlan v30 tag 30

  1. Добавьте маркированные порты в VLAN v20 и v30:

config vlan v20 add tagged 1-4
config vlan v30 add tagged 21-24

  1. Создайте IP-интерфейсы для каждой VLAN:

create ipif IPIF20 192.168.20.2/24 v20 state enable
create ipif IPIF30 192.168.30.2/24 v30 state enable

  1. Настройте протокол RIPv2 на всех IP-интерфейсах коммутатора:

enable rip
config rip all tx_mode v2_only rx_mode v2_only state enable
Настройка коммутатора SW2

  1. Удалите порты из VLAN по умолчанию и создайте новые VLAN:

config vlan default delete 1-4,9-12,19-24
create vlan v20 tag 20
create vlan v40 tag 40
create vlan v50 tag 50

  1. В созданные VLAN добавьте немаркированные и маркированные порты:

config vlan v20 add tagged 1-4
config vlan v40 add tagged 19-24
config vlan v50 add untagged 9-12

  1. Создайте IP-интерфейсы для каждой VLAN:

create ipif IPIF20 192.168.20.1/24 v20 state enable
create ipif IPIF40 192.168.40.1/24 v40 state enable
create ipif IPIF50 192.168.50.1/24 v50 state enable

  1. Настройте протокол RIPv2 на всех IP-интерфейсах коммутатора:

enable rip
config rip all tx_mode v2_only rx_mode v2_only state enable
Настройка коммутатора SW3

  1. Удалите порты из VLAN по умолчанию и создайте новые VLAN:

config vlan default delete 1-6,13-16,21-24
create vlan v30 tag 30
create vlan v40 tag 40
create vlan v60 tag 60

  1. В созданные VLAN добавьте немаркированные и маркированные порты:

config vlan v30 add tagged 21-24
config vlan v40 add tagged 1-6
config vlan v60 add untagged 13-16

  1. Создайте IP-интерфейсы для каждой VLAN:

create ipif IPIF30 192.168.30.1/24 v30 state enable
create ipif IPIF40 192.168.40.2/24 v40 state enable
create ipif IPIF60 192.168.60.1/24 v60 state enable

  1. Настройте протокол RIPv2 на всех IP-интерфейсах коммутатора:

Базовая работа протокола RIP

img

Эта серия статей подробно объясняет основные понятия, принципы и операции протокола маршрутизации RIP с примерами. Узнайте, как работает RIP (Routing Information Protocol) и как обновляет таблицу маршрутизации из широковещательного сообщения шаг за шагом.

Маршрутизаторы используют таблицу маршрутизации для принятия решения о переадресации. Таблица маршрутизации содержит информацию о сетевых путях. Сетевой путь — это простой фрагмент информации, который говорит, какая сеть подключена к какому интерфейсу маршрутизатора.

Всякий раз, когда маршрутизатор получает пакет данных, он ищет в таблице маршрутизации адрес назначения. Если маршрутизатор найдет запись сетевого пути для адреса назначения, он переадресует пакет из связанного интерфейса. Если маршрутизатор не найдет никакой записи для адреса назначения, он отбросит пакет.

Существует два способа обновления таблицы маршрутизации: статический и динамический. В статическом методе мы должны обновить его вручную. В динамическом методе мы можем использовать протокол маршрутизации, который будет обновлять его автоматически. RIP — это самый простой протокол маршрутизации. В этой статье мы узнаем, как RIP обновляет таблицу маршрутизации.

В протоколе RIP маршрутизаторы узнают о сетях назначения от соседних маршрутизаторов через процесс совместного использования. Маршрутизаторы, работающие по протоколу RIP, периодически транслируют настроенные сети со всех портов. Список маршрутизаторов обновит их таблицу маршрутизации на основе этой информации.

Давайте посмотрим, как работает процесс RIP шаг за шагом. Следующий рисунок иллюстрирует простую сеть, работающую по протоколу маршрутизации RIP.

сеть, работающая по протоколу маршрутизации RIP

Когда мы запускаем эту сеть, маршрутизаторы знают только о непосредственно подключенной сети.

  • OFF1 знает, что сеть 10.0.0.0/8 подключена к порту F0/1, а сеть 192.168.1.252/30 подключена к порту S0/0.
  • OFF2 знает, что сеть 192.168.1.252/30 подключена к порту S0/0, а сеть 192.168.1.248/30 подключена к порту S0/1.
  • OFF3 знает, что сеть 20.0.0.0/8 подключена к порту F0/1, а сеть 192.168.1.248/30 подключена к порту S0/0.

В отличие от статической маршрутизации, где мы должны настроить все маршруты вручную, в динамической маршрутизации все, что нам нужно сделать, это просто сообщить протоколу маршрутизации, какой маршрут мы хотим объявить. А остальное будет сделано автоматически, запустив динамический протокол. В нашей сети мы используем протокол маршрутизации RIP, поэтому он будет обрабатываться RIP.

Иногда RIP также известен как маршрутизация прослушки. Потому что в этом протоколе маршрутизации маршрутизаторы изучают информацию о маршрутизации от непосредственно подключенных соседей, а эти соседи учатся от других соседних маршрутизаторов.

Протокол RIP будет совместно использовать настроенные маршруты в сети через широковещательные передачи. Эти широковещательные передачи называются обновлениями маршрутизации. Прослушивающие маршрутизаторы обновят свою таблицу маршрутизации на основе этих обновлений.

маршрутизаторы обновят свою таблицу маршрутизации

  • OFF1 будет слушать трансляцию из OFF2. От OFF2, он узнает об одной новой сети 192.168.1.248/30
  • OFF2 будет слушать две передачи с OFF1 и OFF3. Из OFF1 он узнает о 10.0.0.0/8 и от OFF3 он узнает о сети 20.0.0.0/8.
  • OFF3 будет слушать трансляцию из OFF2. От OFF2 он узнает о сети 192.168.1.252.

Маршрутизатор выполняет несколько измерений, обрабатывая и помещая новую информацию о маршруте в таблицу маршрутизации. Мы объясним их позже в этой статье. Если маршрутизатор обнаружит новый маршрут в обновлении, он поместит его в таблицу маршрутизации.

маршрутизатор обнаружит новый маршрут

Через 30 секунд (интервал времени по умолчанию между двумя обновлениями маршрутизации) все маршрутизаторы снова будут транслировать свои таблицы маршрутизации с обновленной информацией.

В данный момент времени:

маршрутизаторы снова будут транслировать свои таблицы маршрутизации

  • OFF1 будет транслироваться для 10.0.0.0/8, 192.168.1.248/30 и 192.168.1.252/30.
  • OFF2 будет транслировать для 10.0.0.0/8, 20.0.0.0/8, 192.168.1.248/30 и 192.168.1.252/30.
  • OFF3 будет транслироваться для 20.0.0.0/8, 192.168.1.248/30 и 192.168.1.252/30.
  • OFF1 узнает о сети 20.0.0.0/8 из трансляции OFF2.
  • У OFF2 нет ничего, чтобы обновить из трансляции OFF1 и OFF2.
  • OFF3 узнает о сети 10.0.0.0/8 из трансляции OFF2.

Через 30 секунд маршрутизатор снова будет транслировать новую информацию о маршрутизации. На этот раз маршрутизаторам нечего обновлять. Эта стадия называется конвергенцией.

Конвергенция

Конвергенция — это термин, который относится к времени, затраченному всеми маршрутизаторами на понимание текущей топологии сети.

Метрика протокола маршрутизации RIP

У нас может быть два или более путей для целевой сети. В этой ситуации RIP использует измерение, называемое метрикой, чтобы определить наилучший путь для целевой сети. RIP использует подсчет прыжков как метрику. Прыжки — это количество маршрутизаторов, необходимое для достижения целевой сети.

хопы EIGRP

Например, в приведенной выше сети OFF1 есть два маршрута для достижения сети 20.0.0.0/8.

  • Маршрут 1: — через OFF3 [на интерфейсе S0/1]. С прыжком — один.
  • Маршрут 2: — через OFF2-OFF3 [на интерфейсе S0/0]. С прыжком — два.

Итак, по какому маршруту OFF1 доберется до места назначения? Маршрут 1 имеет один прыжок, в то время как маршрут 2 имеет два прыжка. Маршрут 1 имеет меньшее количество переходов, поэтому он будет помещен в таблицу маршрутизации.

Резюме

  • Протокол маршрутизации RIP использует локальную широковещательную передачу для обмена информацией о маршрутизации.
  • RIP транслирует обновления маршрутизации каждые 30 секунд, независимо от того, изменилось что-то в сети или нет. По истечении 30 секунд маршрутизаторы, работающие по протоколу RIP, будут транслировать информацию о своей маршрутизации на любые устройства, подключенные к их интерфейсам.
  • Перед отправкой обновлений маршрутизации маршрутизатор добавляет метрику инициализации ко всем маршрутам, которые он имеет, и увеличивает метрику входящих маршрутов в объявлениях, чтобы маршрутизатор листинга мог узнать, как далеко находится сеть назначения.
  • При отправке широковещательных передач RIP не заботится о том, кто слушает эти широковещательные обновления или нет.
  • После отправки широковещательного сообщения RIP не заботится о том, получили ли соседи эти широковещательные обновления или нет.
  • Когда маршрутизатор получает обновления маршрутизации, он сравнивает их с маршрутами, которые уже есть в его таблице маршрутизации.
  • Если обновление содержит информацию о маршруте, которая недоступна в его таблице маршрутизации, маршрутизатор будет рассматривать этот маршрут как новый маршрут.
  • Маршрутизатор добавит все новые маршруты в таблицу маршрутизации перед обновлением существующего.
  • Если обновление содержит лучшую информацию для любого существующего маршрута, маршрутизатор заменит старую запись новым маршрутом.
  • Если обновление содержит худшую информацию для любого существующего маршрута, маршрутизатор проигнорирует ее.
  • Если обновление содержит точно такую же информацию о любом существующем маршруте, маршрутизатор сбросит таймер для этой записи в таблице маршрутизации

Настройка протокола RIP на маршрутизаторах Cisco

Звезда активнаЗвезда активнаЗвезда активнаЗвезда активнаЗвезда не активна

Формирование у студентов устойчивых навыков конфигурирования маршрутизаторов для работы с протоколом динамической маршрутизации RIP.

Ход работы

Для начала разберемся с тем, что же такое протокол динамической маршрутизации, какие особенности имеет протокол RIP и как он работает. Затем смоделируем сеть и настроим в ней протокол RIP. Наконец, посмотрим, с помощью каких команд проверяется работоспособность этого протокола.

Обзор протокола RIP

У всех протоколов динамической маршрутизации одна цель – строить оптимальную сетевую топологию без петель.

В данной лабораторной работе рассматривается RIPv2 (версии 2). RIP любой версии относится к протоколам маршрутизации внутреннего шлюза, является дистанционно-векторным протоколом и не учитывает состояния каналов. В качестве метрики в протоколе используется счетчик транзитных устройств, который учитывает, через сколько маршрутизаторов (или других L3-устройств) пролегает маршрут к сети. RIP осуществляет медленную конвергенцию и по умолчанию имеет одну из наибольших стандартных административных дистанций — 120. Конвергенцией называется процесс сходимости сети, то есть процесс обнаружения изменений в сети, поиска и построения оптимальной топологии. Каждый протокол маршрутизации имеет особое число, называемое административным расстоянием, необходимое для того, чтобы система IOS могла выбрать предпочтительный маршрут, если настроено несколько протоколов маршрутизации. Стоит также отметить, что в некоторых протоколах маршрутизации происходит деление маршрутов на внутренние и внешние, в этом случае AD различным типам маршрутов назначается отдельно. Стандартные значения AD для маршрутизаторов Cisco и других производителей могут отличаться. Кроме того, RIP не позволяет суммировать маршруты с маской короче классовой.

Для работы RIP использует четыре таймера, перечисленные в таблице ниже.

Название Значение по умолчанию Предназначение
Update timer 30 секунд Отвечает за частоту отправки обновлений соседям.
Invalid timer 180 секунд Отвечает за время хранения информации о маршруте в таблице маршрутизации без получения обновления. Если обновление о маршруте не будет получено за это время, ему присваивается метрика 16 (недоступный).
Flush timer 240 секунд Время, через которое маршрут исключается из таблицы маршрутизации.
Holddown timer 180 секунд Является функциональностью исключительно оборудования Cisco. Запускается для недостижимого маршрута. В течение этого времени маршрут хранится как недоступный, его статус не изменяется даже при получении обновлений об этой сети.

Моделирование и настройка

Реализуем следующую сеть.

Для начала настроим все необходимые интерфейсы. На R1 это loopback, моделирующий сеть клиента, и интерфейс в сторону провайдера.

R1(config)# int lo1
R1(config-if)#ip addr 10.1.1.1 255.255.255.0
R1(config-if)# int g0/0
R1(config-if)#ip addr 199.1.1.1 255.255.255.252
R1(config-if)# no shutdown

Аналогично на R5.

R5(config)# int lo1
R5(config-if)#ip addr 10.2.2.2 255.255.255.0
R5(config-if)# int g0/0
R5(config-if)#ip addr 199.2.1.2 255.255.255.252
R5(config-if)# no shutdown

На R2 – интерфейсы GigabitEthernet и один интерфейс FastEthernet.

R2(config)# int g0/0
R2(config-if)#ip addr 199.1.1.2 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# int g2/0
R2(config-if)#ip addr 199.11.1.1 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# int f1/0
R2(config-if)#ip addr 199.10.1.2 255.255.255.252
R2(config-if)# no shutdown

Аналогично на R3 и на R4.

R3(config)# int g0/0
R3(config-if)#ip addr 199.2.1.1 255.255.255.252
R3(config-if)# no shutdown
R3(config-if)# int g2/0
R3(config-if)#ip addr 199.12.1.2 255.255.255.252
R3(config-if)# no shutdown
R3(config-if)# int f1/0
R3(config-if)#ip addr 199.10.1.1 255.255.255.252
R3(config-if)# no shutdown
R4(config)# int g0/0
R4(config-if)#ip addr 199.11.1.2 255.255.255.252
R4(config-if)# no shutdown
R4(config-if)# int g1/0
R4(config-if)#ip addr 199.12.1.1 255.255.255.252
R4(config-if)# no shutdown

В настоящий момент локальные сети клиента 10.1.1.1 и 10.2.2.2 не видят друг друга (отсутствует соответствующая маршрутная информация). Перейдём к настройке RIP. На каждом маршрутизаторе необходимо ввести следующие команды: в режиме глобальной конфигурации router rip, чтобы перейти в режим конфигурации протокола; network адрес_сети, чтобы включить протокол на нужных интерфейсах. Необходимо помнить, что в качестве адреса сети команды network нужно указывать только адрес классовой сети. Кроме того, введем команду no auto-summary для отключения суммирования сетей на границе маршрутизации.

Пример настройки маршрутизатора R1.

R1(config)# router rip
R1(config-router)# network 199.1.1.0
R1(config-router)# redistribute connected
R1(config-router)# no auto-summary

Замечание: если бы во второй строке мы указали в качестве сети адрес 10.1.1.0, система не выдала бы никаких ошибок и предупреждений, тем не менее, протокол RIP включился бы на всех интерфейсах, подсети которых входили бы в сеть 10.0.0.0/8.

Важное замечание: с помощью команды redistribute connected мы добавили сети всех подключенных интерфейсов (в том числе и сеть интерфейса loopback) в базу данных протокола RIP – RIP DataBase (RDB), но не включили сам протокол на этих интерфейсах. Таким образом, информация об этой сети рассылается протоколом через все интерфейсы, на которых функционирует RIP (в нашем случае через gi0/0), но при этом остальные интерфейсы не рассылают RIP-пакеты и не слушают сеть на предмет входящих RIP-сообщений.

Пример настройки маршрутизатора R2.

R2(config)# router rip
R2(config-router)# network 199.10.1.0
R2(config-router)# network 199.1.1.0
R2(config-router)# network 199.11.1.0
R2(config-router)# no auto-summary

Настройка маршрутизатора R3.

R3(config)# router rip
R3(config-router)# network 199.10.1.0
R3(config-router)# network 199.2.1.0
R3(config-router)# network 199.12.1.0
R3(config-router)# no auto-summary

Настройка маршрутизатора R4.

R4(config)# router rip
R4(config-router)# network 199.12.1.0
R4(config-router)# network 199.11.1.0
R4(config-router)# no auto-summary

Настройка маршрутизатора R5.

R5(config)# router rip
R5(config-router)# network 199.2.1.0
R5(config-router)# redistribute connected
R5(config-router)# no auto-summary

Если на данном этапе настройки попытаться выполнить команду ping 10.2.2.2 source 10.1.1.1 c R1, то маршрутизатор сообщит о недоступности узла с адресом 10.2.2.2. Дело в том, что по умолчанию запускается RIPv1, который поддерживает только с классовые сети. То есть в нашем случае в базу данных протокола будет добавлена только одна сеть вместо двух: 10.0.0.0/8 вместо 10.1.1.0/24 и 10.2.2.0/24, потому что RIPv1 не учитывает маски этих сетей. Убедиться в этом можно путём просмотра таблицы маршрутизации и RDB на R2 и R3, которым маршрутизаторы R1 и R5 сообщают только о сети 10.0.0.0/8. Исправьте возникшую проблему, прописав команду version 2 в режиме конфигурирования протокола маршрутизации на всех устройствах.

На этом настройка устройств завершена, перейдём непосредственно к тестированию.

Тестирование

1. С помощью команд ping 10.2.2.2 source 10.1.1.1 и trace 10.2.2.2 source 10.1.1.1, выполненных с маршрутизатора R1, убедитесь, что локальные сети клиента имеют доступ друг к другу.

2. Проанализируйте маршрут, которым следуют пакеты между двумя сетями, указанными в предыдущем пункте.

3. Отключите низкоскоростной канал между маршрутизаторами R2 и R3. Как изменится маршрут следования пакетов между сетями?

4. Используя команду show ip protocols, проверьте настройки RIP на каждом маршрутизаторе.

5. Введите команду show ip route rip и проанализируйте её вывод.

6. Выполните перехват трафика между маршрутизаторами и проанализируйте сообщения RIP.

7. С помощью перехвата из предыдущего пункта продемонстрируйте работу метода расщепления горизонта в RIP.

«Плавающий» статический маршрут

В настроенной выше схеме трафик передаётся через канал FastEthernet, что может быть неэффективно из-за меньшей по сравнению с GigabitEthernet пропускной способностью. В этом пункте мы настроим так называемый «плавающий» маршрут, который поможет решить эту проблему.

Для начала необходимо отключить RIP на интерфейсах fa1/0 на R2 и R3.

R2(config)# router rip
R2(config-router)# no network 199.10.1.0
R3(config)# router rip
R3(config-router)# no network 199.10.1.0

Теперь настроим статические маршруты в сторону сетей на интерфейсах loopback, но с административной дистанцией равно 130.

R2(config)# ip route 10.2.2.0 255.255.255.0 199.10.1.1 130
R3(config)# ip route 10.1.1.0 255.255.255.0 199.10.1.2 130

Добавим эти маршруты в RIP (самостоятельно объясните, для чего это нужно).

R2(config)# router rip
R2(config-router)# redistribute static
R3(config)# router rip
R3(config-router)# redistribute static

С помощью команды trace 10.2.2.2 source 10.1.1.1, выполненной с маршрутизатора R1, убедимся, что пакеты идут через R4. Кроме того, посмотрим таблицу маршрутизации на R2 с помощью команды show ip route и убедимся, что статического маршрута в ней нет.

Теперь выключим интерфейсы в сторону R4.

R2(config)# int g2/0
R2(config-if)# shutdown
R3(config)# int g2/0
R3(config-if)# shutdown

Снова посмотрим таблицу маршрутизации и убедимся, что статический маршрут появился в таблице маршрутизации. Повторим с помощью команды trace 10.2.2.2 source 10.1.1.1 с R1, что связность сети не нарушена.

You have no rights to post comments

OSPF, RIP и BGP простым языком. Часть 1. Протокол RIP

На данный момент почти все люди знают, что такое интернет, но некоторые даже и приблизительно не представляют, как он работает и как за такое короткое время устройства находят друг друга. В этих статьях я решил разобрать основные протоколы маршрутизации, что они из себя представляют и как работают. Данная статья скорее для тех, кто только начал свой путь по сетям и стремится больше узнать о работе маршрутизаторов в небольших и средних локальных сетях (Для крупных чаще всего используется протокол OSPF). Первым разберем протокол RIP. Но сначала немного о маршрутизации…

Маршрутизация

Маршрутизация сама по себе — поиск маршрута доставки пакета между сетями через транзитные узлы — маршрутизаторы, которые позиционируют себя как многофункциональные устройства для разделения сетей. Вся сеть интернет разделена на крупные автономные системы (AS), которые связываются и узнают друг о друге с помощью внешних протоколов маршрутизации,

Этапы маршрутизации:

1. Изучение сети

Здесь и начинается самое интересное:) В более менее крупных сетях, где используется динамическая(адаптивная) маршрутизация, все изменение конфигурации сети автоматически отражаются в таблицах маршрутизации благодаря протоколам маршрутизации. Протоколы маршрутизации делятся на внешние протоколы (BGP) и внутренние (OSPF и RIP). Внешние протоколы маршрутизируют трафик среди автономных систем, грубо говоря, подсети провайдеров объединяют внешние протоколы, объединенные внешним маршрутизатором. А внутренние протоколы маршрутизации изучают сеть с помощью других протоколов, таких как OSPF или RIP (чаще всего используют OSPF).

RIP (Routing Information Protocol — протокол машрутной информации) является внутренним протоколом маршрутизации дистанционно-векторного типа (что это значит я опишу уже в следующей статье). Будучи простым в реализации он в основном использовался в небольших сетях, хотя сейчас он уже сильно устарел и редко используется в более менее современных компаниях. Его работу я опишу вкратце, дабы не забивать вам голову устаревшей информацией.
Этап 1 — создание минимальной таблицы. В исходном состоянии на каждом маршрутизаторе программным обеспечением стека TCP/IP автоматически создается минимальная таблица маршрутизации, в которой учитываются только непосредственно подсоединенные сети.
Пример таблицы маршрутизатора с 3 подсоединенными портами.

Номер сети Адрес следущего маршрутизатора Порт Расстояние
201.36.14.0 201.36.14.3 1 1
132.11.0.0 132.11.0.7 2 1
194.27.18.0 194.27.18.1 3 1

Этап 2 — рассылка минимальной таблицы соседям. После создания своих минимальных таблиц, маршрутизатор начинает рассылать своим соседям сообщения протокола RIP. Сообщения, которые передаются в дейтаграммах UDP, включают в себя информацию о каждой сети: её IP-адрес и расстояние до неё от передающего маршрутизатора.

Этап 3 — получение RIP-сообщений от соседей и обработка полученной информации. Наш маршрутизатор, после получения сообщений от соседних маршрутизаторов, увеличивает каждое поле метрики на 1 и запоминает, через какой порт и от какого маршрутизатора получена информация, после сравнивает значения со своей таблицей.

Этап 4 — рассылка новой таблицы соседям. Сконфигурированную таблицу маршрутизатор снова отправляет всем своим соседям. В ней хранится информация не только о сетях, к которым маршрутизатор подключен напрямую, но и о удаленных, о которых он узнал от соседних маршрутизаторов на втором этапе. Думаю тут начинает становиться понятно, почему протокол RIP используется в основном в небольших сетях.

Этап 5 — получение таблиц и обработка полученной информации. Тут все, как на 3 этапе — маршрутизатор получает таблицу и сравнивает со своей, внося изменения.

2. Продвижение пакетов на маршрутизаторе

С этим все достаточно просто: пакет поступает на маршрутизатор, маршрутизатор проверяет свою таблицу маршрутизации и отправляет на указанный порт.

На этом в приницпе заканчиваются основные методы работы протокола RIP, oднако в сетях постоянно происходят изменения — меняются маршрутизаторы, перестраиваются линии связи, к тому же, могут создаваться новые сети, а старые могут выводиться из состава.

Для адаптации к изменениям в сети протокол RIP использует ряд механизмов.

Адаптация маршрутизаторов RIP к изменениям состояние сети.

К новым маршрутам маршрутизаторы RIP приспосабливается безболезненно — они передают новую информацию в очередном сообщении своим соседям и постепенно эта информация становится известна всем маршрутизаторам сети. А вот с потерей какого-либо маршрута протокол справляется достаточно проблематично. Это связано с тем, что в формате сообщений протокола RIP нет поля, которое бы указывало на то, что путь к данной сети больше не существует.

Для уведомления о том, что данный маршрут недействителен, используются механизм истечения времени жизни маршрута.

Механизм основан на том, что обмен таблицами маршрутизации в протоколе RIP происходит раз в 30 секунд, время тайм-аута — в 6 раз больше, то есть 180 секунд, и маршрутизатор, получивший сообщение с подтверждением записи маршрута, ставит таймер в исходное состояние и если в течении времени тайм-аута (180 секунд) подтверждение не приходит еще раз, то маршрут становится недействительным.

Шестикратное время тайм-аута нужно для того, чтобы была точная уверенность, что маршрут недействителен, а не пакеты потерялись (ведь протокол использует транспортный протокол UDP).

В принципе я старался максимально просто объяснить протокола и надеюсь у меня это получилось:)

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *