Как добавить кнопку присоединенные файлы 1с
Перейти к содержимому

Как добавить кнопку присоединенные файлы 1с

  • автор:

1с программное присоединение файла к документу

1с программное присоединение файла к документу

Сегодня делал небольшую доработку 1с УНФ написанную на БСП 3.1. Задача была сделать кнопку, которая рассылала бы отчет определенным адресатам и сам отчет был бы во вложении. На основании рассылки должны были создаваться документы событие и вложенные фалы должны быть там приложены.

Сохранить файл или записать файл для программиста 1с не сложная задача. Тут можно прочитать про диалоги работы с файлами.

Написав функционал по рассылкам и создав событие, столкнулся с выбором как мне быстрее и проще реализовать прикрепление файла к документу объекту. Выбрал функцию БСП, что бы отчет не требовал доработок при обновлении УНФ, а также что бы не писать много кода.

Код ниже берет файл с диска и прикрепляет его к объекту.

// Готовим файл и помещаем его в хранилище ИмяФайлаНаДиске = "C:\Users\v.burmistrov\Downloads\ффд12.pdf"; ДвоичныеДанные = Новый ДвоичныеДанные(ИмяФайлаНаДиске); ВременноеХранилище = ПоместитьВоВременноеХранилище(ДвоичныеДанные); // Подготоваливаем описание файла заполнив все необходимые параметры ПараметрыФайла = РаботаСФайлами.ПараметрыДобавленияФайла(); ПараметрыФайла.Автор = Пользователи.ТекущийПользователь(); ПараметрыФайла.ВладелецФайлов = ДокументСсылка; ПараметрыФайла.ИмяБезРасширения = СтрЗаменить(ИмяФайлаНаДиске,".pdf",""); ПараметрыФайла.РасширениеБезТочки = "pdf"; // Используем функцию БСП и добавляем файл к объекту РаботаСФайлами.ДобавитьФайл(ПараметрыФайла, ВременноеХранилище);

10 строк кода и задача решена. Используйте БСП, изучайте БСП. Программное присоединение файла к документу в 1с с помощью БСП это очень просто и быстро, написать самому весь код с нуля заняло бы минут 30.

В типовых базах есть два типа объектов:

  1. Объекты для которых создан справочник для файлов и все файлы хранятся в нем. Например: СобытиеПрисоединенныеФайлы
  2. Объекты для которых нет специального справочника, файлы хранятся в справочнике Файлы.

Для второго типа объектов нужно использовать другой код.

ИмяФайлаНаДиске = "C:\Users\v.burmistrov\Downloads\ффд12.pdf"; РаботаСФайлами.ДобавитьФайлСДиска(ДокументСсылка, ИмяФайлаНаДиске);

Благодаря этой заметке программное присоединение файла к документу в 1с теперь не проблема.

Дополнительные материалы по теме:

Как прикрепить внешний файл

В данной статье показано, как нужно делать прикрепление файлов произвольного формата к документам и справочникам 1С:Предприятие 8.

Прикрепление файлов в 1С:Бухгалтерия предприятия 3.0

В бухгалтерской конфигурации есть возможность прикреплять только к документам. Для примера возьмем документы Поступление товаров и услуг, откроем любой:

добавить файл к документу в 1с

В верхней командной панели нажимаем на иконку со скрепкой:

файл прицепить к 1с

В открывшейся форме будут храниться все прикрепленные к документу файлы. Расширение файлов может быть произвольное. Если прикрепляется картинка, то в окне справа она будет открываться для предварительного просмотра. Нажимаем Добавить, в появившемся диалоговом окне выбираем нужный файл. После этого он появится в списке:

файл прицепить к 1с

Если нужно добавить несколько файлов, повторяем это действие. После возвращения в список документов видим, что напротив данной накладной появилось изображение скрепки, это говорит о том, что к документу есть прикрепленные файлы:

прикрепление файлов к 1с

Просмотреть прикрепленные к документу файлы или добавить новые мы можем не только из карточки документа, но и из списка — в командной панели также видим иконку со скрепкой. При необходимости нужно выделить строку с нужным документом и нажать на эту кнопку.

добавить файл к документу в 1с

Прикрепление файлов в Управление торговлей 11, Комплексная автоматизация 2.0, ERP 2.1

В перечисленных конфигурациях файлы можно прикреплять не только к документам, но и к справочникам.

В формах документов для прикрепления используем ссылку Файлы:

прикрепление файлов к 1с

В открывшемся окне будет храниться список всех добавленных файлов.

прикрепление файлов к 1с

Для демонстрации прикрепления файлов к справочникам откроем любой справочник, например, карточку партнера:

прикрепление файлов к 1с

В карточке справочника для доступа к присоединенным файлам также используем ссылку Файлы.

Дмитрий Медведков 1С

Дмитрий Медведков программист, консультант 1С
Работаю в 1С с 2012-го, специализируюсь на УТ 11
Имею 10 квалифиционных сертификатов 1C:Профессионал, 1С:Специалист и 1С:Специалист-консультант

Присоединенные файлы

Предназначен для работы с файлами, присоединенными к объекту программы.

Открывается по команде Присоединенные файлы панели навигации объекта программы.

В списке выводится:

  • — наличие ЭП или шифрования.
  • Наименование — полное имя файла. Значок рядом с наименованием указывает тип файла. При наличии в колонке выводится также и описание — подробные сведения о файле.
  • Автор — пользователь, который добавил файл;
  • Дата изменения — дата изменения данных файла (местное время);

С помощью команды Еще — Дополнительно — Изменить форму можно добавить сведения:

Дата создания — дата и время ввода файла в программу;

  • Редактирует — пользователь, который занял файл для редактирования и т.д.

Добавление нового файла

Нажмите Добавить. Выберите способ ввода файла из выпадающего меню:
Файл с диска;
укажите путь к файлу на компьютере.
По шаблону;
выберите шаблон из предлагаемого списка.
со сканера.
открывается окно для работы со сканированием. Следуйте указаниям программы.
Файл хранится в специальном каталоге. Для каждого объекта программы формируется отдельная папка.
В некоторых списках программы элементы, к которым присоединены файлы, обозначаются значком .

Просмотр изображений в списке

Включите флажок Еще — Предпросмотр, для того чтобы можно было просматривать файлы изображений прямо в списке в специальном окне.

Просмотр карточки файла

  • Нажмите Еще — Открыть карточку (нажмите клавишу F2), для того чтобы просмотреть свойства выделенного в списке файла, открыв окно Присоединенный файл, также можно воспользоваться соответствующей командой контекстного меню.

Редактирование присоединенных файлов

В тонком клиенте редактирование файлов табличных документов (формата .mxl) осуществляется во встроенной форме редактора табличных документов. В веб-клиенте необходимо загрузить приложение для редактирования этих файлов. Подробнее об особенностях редактирования табличных документов в веб-клиенте см. здесь.

Для редактирования файлов других форматов на компьютере должны быть установлены соответствующие приложения, например, для редактирования файлов в формате Microsoft Word должно быть установлено это приложение.

Команда Редактировать открывает файл в режиме редактирования, а также производит захват файла в программе. Захваченный файл будет недоступен для редактирования другим пользователям программы и помечается в списке зеленым цветом.

После окончания редактирования сохраните файл, закройте внешнее приложение. Нажмите Сохранить и освободить файл в информационной базе, это действие освобождает файл, сохраняет его в программе и снимает пометку занятости для редактирования.

Команда Еще — Отменить редактирование освобождает файл, не сохраняя произведенные в нем изменения в программе, и снимает пометку занятости для редактирования. Команда может быть полезна, если необходимо отказаться от результатов редактирования файла (например, при редактировании в файл были внесены нежелательные изменения или ошибки).

Печать файла

Нажмите кнопку Печать.

Отправка файла по электронной почте

Нажмите кнопку Отправить. Программа формирует почтовое сообщение, заполните необходимые поля. Присоединенный файл автоматически будет приложением данного письма.

Сохранение файла

С помощью команды Еще — Сохранить как можно сохранить файл в указанный каталог на жестком или сетевом диске.

Также можно воспользоваться соответствующей командой контекстного меню по правой кнопке мыши.

Соответствующей командой меню Еще или контекстного меню по правой кнопке мыши можно Открыть каталог файла в Проводнике Windows.

Обновление файла

  • С помощью команды Еще — Обновить из файла на диске можно обновить файл из оригинального файла на диске (из которого изначально был создан файл в программе).
  • Также можно воспользоваться соответствующей командой контекстного меню по правой кнопке мыши.

Сравнение файлов

Выберите в списке файлы для сравнения.

Выполните команду Еще — Сравнить файлы. При первом сравнении файлов программа предлагает выбрать, с помощью какой офисной программы выполнить сравнение. После этого открываются файлы для сравнения в выбранной офисной программе. Программа для сравнения должна быть установлена на компьютере.

Электронная подпись и шифрование

В выпадающем меню по кнопке Электронная подпись и шифрование доступны команды для работы с электронной подписью файлов:

  • Подписать — создает ЭП для файла. Перед созданием ЭП программа предлагает выбрать сертификат ЭП из имеющихся на компьютере. Выбор сертификата можно сделать и во время персональных настроек программы. Подписанный файл становится недоступным для редактирования и отображается в списках со значком .
  • Сохранить вместе с электронной подписью — сохраняет подпись в файл на диске. Команду можно использовать, например, если необходимо передать подписанный файл другому лицу.
  • Добавить электронную подпись из файла — добавляет подпись к файлу. Команду можно использовать, например, если подпись (файл подписи) была получена позже, чем подписанный файл.
  • Зашифровать — по команде происходит шифрование файла. В отличие от подписания могут использоваться несколько сертификатов, например, если необходимо зашифровать файл для нескольких пользователей. Зашифрованный файл в списках отображается со значком .
  • Расшифровать — по команде происходит расшифровка файла. Для расшифровки нужно ввести пароль к закрытому ключу.

Печать табличного документа со штампом электронной подписи

Для печати подписанного электронной подписью табличного документа со штампами визуализации электронной подписи в списке присоединенных файлов предусмотрена команда Печать — Со штампом элоектронной подписи.

Предварительно, табличный документ должен быть подписан одной или несколькими электронными подписями в соответствии с тем, как это предусмотрено в документе.

1С БСП работа с файлами

Функционал БСП по загрузке файлов, позволяет к любому справочнику или документу прикрепить файл или документ, в том числе возможно добавление файла напрямую со сканера.

В нашем случае для документа _ДемоСчетНаОплатуПокупателю, необходимо реализовать возможно прикрепления файла, для этого необходимо.

Создаем справочник для хранения файлов

Создаем одноименный справочник и в конце наименования добавляем текст “ПрисоединенныеФайлы“, получается _ДемоСчетНаОплатуПокупателюПрисоединенныеФайлы. Должно получится, как на рисунке ниже.

Структура справочника, такая

Справочник можно скопировать из уже существующей конфигурации, переименовать, как нужно и важно изменить тип реквизита ВладелецФайла, в нашем случае указать документ _ДемоСчетНаОплатуПокупателюПрисоединенныеФайлы.

Расширяем определяемые типы

Для типа Присоединенный Файл, добавляем в состав ссылку на созданный справочник с файлами

Для типа Присоединенный ФайлОбъект, добавляем в состав тот же справочник, но с типом Объект.

Для типа ВладелецПрисоединенныхФайлов, добавляем в состав ссылку на документ, то есть на владельца файлов

Тип ВладелецПрисоединенныхФайловОбъект, расширяется только в случае добавления файлов для справочников, для документа состав изменять не нужно.

Для определяемого типа ПереопределитьПолучаемуюФормуПрисоединенногоФайла, выбираем СправочникМенедежер созданный для файлов _ДемоСчетНаОплатуПокупателюПрисоединенныеФайлы.

Для определяемого типа УстановитьПометкуУдаленияПрисоединенныхФайловДокументов, добавим в состав ДокументОбъект _ДемоСчетНаОплатуПокупателю, для справочников данный определяемый тип изменять не нужно.

Добавляем необходимые обработчики

В форму документа добавим следующие обработчики из подсистемы работы с файлами:

&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) // СтандартныеПодсистемы.РаботаСФайлами ГиперссылкаФайлов = РаботаСФайлами.ГиперссылкаФайлов(); ГиперссылкаФайлов.Размещение = "Файлы"; РаботаСФайлами.ПриСозданииНаСервере(ЭтотОбъект, ГиперссылкаФайлов); // Конец СтандартныеПодсистемы.РаботаСФайлами КонецПроцедуры
&НаКлиенте Процедура ПриОткрытии(Отказ) // СтандартныеПодсистемы.РаботаСФайлами РаботаСФайламиКлиент.ПриОткрытии(ЭтотОбъект, Отказ); // Конец СтандартныеПодсистемы.РаботаСФайлами КонецПроцедуры
&НаКлиенте Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник) // СтандартныеПодсистемы.РаботаСФайлами РаботаСФайламиКлиент.ОбработкаОповещения(ЭтотОбъект, ИмяСобытия); // Конец СтандартныеПодсистемы.РаботаСФайлами КонецПроцедуры

С обработчиками формы закончено, дальше добавляем код:

// СтандартныеПодсистемы.РаботаСФайлами &НаКлиенте Процедура Подключаемый_ПолеПредпросмотраНажатие(Элемент, СтандартнаяОбработка) РаботаСФайламиКлиент.ПолеПредпросмотраНажатие(ЭтотОбъект, Элемент, СтандартнаяОбработка); КонецПроцедуры &НаКлиенте Процедура Подключаемый_ПолеПредпросмотраПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка) РаботаСФайламиКлиент.ПолеПредпросмотраПроверкаПеретаскивания(ЭтотОбъект, Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка); КонецПроцедуры &НаКлиенте Процедура Подключаемый_ПолеПредпросмотраПеретаскивание(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка) РаботаСФайламиКлиент.ПолеПредпросмотраПеретаскивание(ЭтотОбъект, Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка); КонецПроцедуры // Конец СтандартныеПодсистемы.РаботаСФайлами
// СтандартныеПодсистемы.РаботаСФайлами &НаКлиенте Процедура Подключаемый_КомандаПанелиПрисоединенныхФайлов(Команда) РаботаСФайламиКлиент.КомандаУправленияПрисоединеннымиФайлами(ЭтотОбъект, Команда); КонецПроцедуры // Конец СтандартныеПодсистемы.РаботаСФайлами

После запуска, в форме документа должна появиться кнопка для добавления файлов, для просмотра файлов, необходимо кликнуть по надписи Файлы.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *